Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "Provides both a high- and low-level interface to the HDF5 library from Python." |
| 2 | HOMEPAGE = "https://www.h5py.org/" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "BSD-3-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=113251d71fb0384712c719b567261c5c" |
| 6 | |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 7 | SRC_URI[sha256sum] = "3fcf37884383c5da64846ab510190720027dca0768def34dd8dcb659dbe5cbf3" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 8 | |
| 9 | SRC_URI:append = " \ |
| 10 | file://0001-setup_build.py-avoid-absolute-path.patch \ |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 11 | file://0001-fix-wrong-file-driver-version.patch \ |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 12 | " |
| 13 | |
| 14 | inherit pkgconfig pypi setuptools3 |
| 15 | |
| 16 | BBCLASSEXTEND = "native" |
| 17 | |
| 18 | DEPENDS = "python3-pkgconfig-native \ |
| 19 | python3-cython-native \ |
| 20 | python3-numpy-native \ |
| 21 | python3-six-native \ |
| 22 | hdf5-native \ |
| 23 | python3 \ |
| 24 | hdf5 \ |
| 25 | " |
| 26 | |
| 27 | RDEPENDS:${PN} = "python3-numpy \ |
| 28 | python3-six \ |
| 29 | python3-json \ |
| 30 | " |
| 31 | |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 32 | export HDF5_VERSION="1.13.2" |