Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame^] | 1 | DESCRIPTION = "A portable, lightweight MessagePack serializer and deserializer written in pure Python." |
| 2 | |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=31e3e7e79c4e2dafffffdd0b4d40c849" |
| 5 | |
| 6 | SRC_URI[sha256sum] = "e86f7ac6aa0ef4c6c49f004b4fd435bce99c23e2dd5d73003f3f9816024c2bd8" |
| 7 | |
| 8 | inherit pypi setuptools3 ptest |
| 9 | |
| 10 | SRC_URI += " \ |
| 11 | file://run-ptest \ |
| 12 | " |
| 13 | |
| 14 | RDEPENDS:${PN}-ptest += " \ |
| 15 | ${PYTHON_PN}-pytest \ |
| 16 | " |
| 17 | |
| 18 | do_install_ptest() { |
| 19 | cp -f ${S}/test_umsgpack.py ${D}${PTEST_PATH}/ |
| 20 | } |
| 21 | |
| 22 | RDEPENDS:${PN} += " \ |
| 23 | ${PYTHON_PN}-datetime \ |
| 24 | " |
| 25 | |
| 26 | BBCLASSEXTEND = "native nativesdk" |