Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame^] | 1 | SUMMARY = "Python 2 and 3 compatibility library" |
| 2 | HOMEPAGE = "https://xlsxwriter.readthedocs.io" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=12d9fac1f0049be71ab5aa4a78da02b0" |
| 6 | |
| 7 | inherit pypi setuptools3 |
| 8 | |
| 9 | PYPI_PACKAGE = "XlsxWriter" |
| 10 | |
| 11 | RDEPENDS:${PN} += " \ |
| 12 | python3-crypt \ |
| 13 | python3-datetime \ |
| 14 | python3-compression \ |
| 15 | python3-numbers \ |
| 16 | python3-io \ |
| 17 | " |
| 18 | |
| 19 | SRC_URI[sha256sum] = "fe2b1e2dec38ef8952e9a41a0290861a052e6771a9f43f5e3d56dc63b7112348" |
| 20 | |
| 21 | BBCLASSEXTEND = "native nativesdk" |