Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame^] | 1 | SUMMARY = "Tools for TPM2." |
| 2 | DESCRIPTION = "tpm2-tools" |
| 3 | LICENSE = "BSD-3-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://docs/LICENSE;md5=a846608d090aa64494c45fc147cc12e3" |
| 5 | SECTION = "tpm" |
| 6 | |
| 7 | DEPENDS = "tpm2-abrmd tpm2-tss openssl curl autoconf-archive" |
| 8 | |
| 9 | SRC_URI = "https://github.com/tpm2-software/${BPN}/releases/download/${PV}/${BPN}-${PV}.tar.gz" |
| 10 | |
| 11 | SRC_URI[sha256sum] = "e7ce2fd36ef5cdbd7872d823a442e8754a4f0ca7c54b60efcdb75c12a1f98f8f" |
| 12 | |
| 13 | UPSTREAM_CHECK_URI = "https://github.com/tpm2-software/${BPN}/releases" |
| 14 | |
| 15 | inherit autotools pkgconfig bash-completion |
| 16 | |
| 17 | do_configure:prepend() { |
| 18 | # do not extract the version number from git |
| 19 | sed -i -e 's/m4_esyscmd_s(\[git describe --tags --always --dirty\])/${PV}/' ${S}/configure.ac |
| 20 | } |
| 21 | |
| 22 | # need tss-esys |
| 23 | RDEPENDS:${PN} = "libtss2 tpm2-abrmd" |