Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame^] | 1 | DESCRIPTION = "There are two major versions of the PCRE library. The \ |
| 2 | newest version is PCRE2, which is a re-working of the original PCRE \ |
| 3 | library to provide an entirely new API. The original, very widely \ |
| 4 | deployed PCRE library's API and feature are stable, future releases \ |
| 5 | will be for bugfixes only. All new future features will be to PCRE2, \ |
| 6 | not the original PCRE 8.x series." |
| 7 | SUMMARY = "Perl Compatible Regular Expressions version 2" |
| 8 | HOMEPAGE = "http://www.pcre.org" |
| 9 | SECTION = "devel" |
| 10 | LICENSE = "BSD-3-Clause" |
| 11 | LIC_FILES_CHKSUM = "file://LICENCE;md5=41bfb977e4933c506588724ce69bf5d2" |
| 12 | |
| 13 | SRC_URI = "${GITHUB_BASE_URI}/download/pcre2-${PV}/pcre2-${PV}.tar.bz2" |
| 14 | |
| 15 | GITHUB_BASE_URI = "https://github.com/PhilipHazel/pcre2/releases" |
| 16 | UPSTREAM_CHECK_REGEX = "releases/tag/pcre2-(?P<pver>.+)" |
| 17 | |
| 18 | SRC_URI[sha256sum] = "8d36cd8cb6ea2a4c2bb358ff6411b0c788633a2a45dabbf1aeb4b701d1b5e840" |
| 19 | |
| 20 | CVE_PRODUCT = "pcre2" |
| 21 | |
| 22 | S = "${WORKDIR}/pcre2-${PV}" |
| 23 | |
| 24 | PROVIDES += "pcre2" |
| 25 | DEPENDS += "bzip2 zlib" |
| 26 | |
| 27 | BINCONFIG = "${bindir}/pcre2-config" |
| 28 | |
| 29 | inherit autotools binconfig-disabled github-releases |
| 30 | |
| 31 | EXTRA_OECONF = "\ |
| 32 | --enable-newline-is-lf \ |
| 33 | --with-link-size=2 \ |
| 34 | --with-match-limit=10000000 \ |
| 35 | --enable-pcre2-16 \ |
| 36 | --enable-pcre2-32 \ |
| 37 | " |
| 38 | CFLAGS += "-D_REENTRANT" |
| 39 | CXXFLAGS:append:powerpc = " -lstdc++" |
| 40 | |
| 41 | PACKAGES =+ "libpcre2-16 libpcre2-32 pcre2grep pcre2grep-doc pcre2test pcre2test-doc" |
| 42 | |
| 43 | SUMMARY:pcre2grep = "grep utility that uses perl 5 compatible regexes" |
| 44 | SUMMARY:pcre2grep-doc = "grep utility that uses perl 5 compatible regexes - docs" |
| 45 | SUMMARY:pcre2test = "program for testing Perl-comatible regular expressions" |
| 46 | SUMMARY:pcre2test-doc = "program for testing Perl-comatible regular expressions - docs" |
| 47 | |
| 48 | FILES:libpcre2-16 = "${libdir}/libpcre2-16.so.*" |
| 49 | FILES:libpcre2-32 = "${libdir}/libpcre2-32.so.*" |
| 50 | FILES:pcre2grep = "${bindir}/pcre2grep" |
| 51 | FILES:pcre2grep-doc = "${mandir}/man1/pcre2grep.1" |
| 52 | FILES:pcre2test = "${bindir}/pcre2test" |
| 53 | FILES:pcre2test-doc = "${mandir}/man1/pcre2test.1" |
| 54 | |
| 55 | BBCLASSEXTEND = "native nativesdk" |