Yong Li | 33170c3 | 2019-01-03 11:41:48 +0800 | [diff] [blame] | 1 | SUMMARY = "Intel DBus Interfaces" |
| 2 | DESCRIPTION = "Generated bindings, using sdbus++, for the Intel YAML" |
| 3 | PR = "r1" |
| 4 | PV = "1.0+git${SRCPV}" |
| 5 | LICENSE = "Apache-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| 7 | |
| 8 | S = "${WORKDIR}/git" |
| 9 | |
| 10 | inherit autotools pkgconfig |
Patrick Williams | 5181f43 | 2020-03-31 16:43:15 -0500 | [diff] [blame] | 11 | inherit python3native |
Yong Li | 33170c3 | 2019-01-03 11:41:48 +0800 | [diff] [blame] | 12 | inherit phosphor-dbus-yaml |
| 13 | |
| 14 | DEPENDS += "autoconf-archive-native" |
Patrick Williams | 5181f43 | 2020-03-31 16:43:15 -0500 | [diff] [blame] | 15 | DEPENDS += "${PYTHON_PN}-sdbus++-native" |
Yong Li | 33170c3 | 2019-01-03 11:41:48 +0800 | [diff] [blame] | 16 | |
| 17 | SRC_URI = "git://github.com/openbmc/intel-dbus-interfaces" |
Andrew Geissler | 518a2eb | 2021-11-09 01:40:21 +0000 | [diff] [blame^] | 18 | SRCREV = "2b1255c47fdaaee6fd2db8f38f32abc13a7edf05" |
Yong Li | 33170c3 | 2019-01-03 11:41:48 +0800 | [diff] [blame] | 19 | |
Yong Li | 33170c3 | 2019-01-03 11:41:48 +0800 | [diff] [blame] | 20 | PACKAGECONFIG ??= "libintel_dbus" |
| 21 | PACKAGECONFIG[libintel_dbus] = " \ |
| 22 | --enable-libintel_dbus, \ |
| 23 | --disable-libintel_dbus, \ |
| 24 | systemd sdbusplus, \ |
Patrick Williams | 5181f43 | 2020-03-31 16:43:15 -0500 | [diff] [blame] | 25 | libsystemd \ |
Yong Li | 33170c3 | 2019-01-03 11:41:48 +0800 | [diff] [blame] | 26 | " |
| 27 | |
Jae Hyun Yoo | 24e16a2 | 2021-08-06 10:55:59 -0700 | [diff] [blame] | 28 | PACKAGECONFIG:remove:class-native = "libintel_dbus" |
| 29 | PACKAGECONFIG:remove:class-nativesdk = "libintel_dbus" |
Yong Li | 33170c3 | 2019-01-03 11:41:48 +0800 | [diff] [blame] | 30 | |
Patrick Williams | 5181f43 | 2020-03-31 16:43:15 -0500 | [diff] [blame] | 31 | BBCLASSEXTEND += "native nativesdk" |