Andrew Geissler | 5199d83 | 2021-09-24 16:47:35 -0500 | [diff] [blame^] | 1 | SUMMARY = "Destined to fail" |
| 2 | LICENSE = "CLOSED" |
| 3 | |
| 4 | deltask do_patch |
| 5 | INHIBIT_DEFAULT_DEPS = "1" |
| 6 | |
| 7 | do_shelltest() { |
| 8 | echo "This is shell stdout" |
| 9 | echo "This is shell stderr" >&2 |
| 10 | exit 1 |
| 11 | } |
| 12 | addtask do_shelltest |
| 13 | |
| 14 | python do_pythontest_exit () { |
| 15 | print("This is python stdout") |
| 16 | sys.exit(1) |
| 17 | } |
| 18 | addtask do_pythontest_exit |
| 19 | |
| 20 | python do_pythontest_fatal () { |
| 21 | print("This is python fatal test stdout") |
| 22 | bb.fatal("This is a fatal error") |
| 23 | } |
| 24 | addtask do_pythontest_fatal |