Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | DESCRIPTION = "An icon theme for Gnome" |
| 2 | SECTION = "x11/wm" |
| 3 | LICENSE = "GPLv3" |
| 4 | HOMEPAGE = "http://code.google.com/p/faenza-icon-theme/" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 6 | |
| 7 | inherit allarch gtk-icon-cache |
| 8 | |
| 9 | S = "${WORKDIR}" |
| 10 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 11 | SRC_URI = "http://faenza-icon-theme.googlecode.com/files/${BPN}_${PV}.zip" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 12 | SRC_URI[md5sum] = "e9bd6106d13017ce06d24b586259ae9c" |
| 13 | SRC_URI[sha256sum] = "d4486fda0413f8a81a87e0dd2329f50f2a8a7cb4147b48cf147f0160add8174a" |
| 14 | |
| 15 | do_install() { |
| 16 | install -d ${D}${datadir}/icons |
| 17 | for theme in `find -name 'Faenza*.tar.gz'`; do |
| 18 | tar -xf ${theme} -C ${D}${datadir}/icons |
| 19 | done |
| 20 | tar -xf emesene-faenza-theme.tar.gz -C ${D}${datadir} |
| 21 | mv -f ${D}${datadir}/emesene/themes ${D}${datadir}/themes |
| 22 | rm -rf ${D}${datadir}/emesene |
| 23 | chown -R root:root ${D}${datadir} |
| 24 | } |
| 25 | |
| 26 | FILES_${PN} += "${datadir}/icons ${datadir}/themes" |