Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | DESCRIPTION = "gvfs is a userspace virtual filesystem" |
| 2 | LICENSE = "LGPLv2" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=05df38dd77c35ec8431f212410a3329e" |
| 4 | |
| 5 | GNOMEBASEBUILDCLASS = "meson" |
| 6 | inherit gnome bash-completion gettext upstream-version-is-even |
| 7 | |
Brad Bishop | 34ae600 | 2019-04-08 15:21:03 -0400 | [diff] [blame] | 8 | DEPENDS += "libsecret glib-2.0 gconf libgudev udisks2 polkit shadow-native" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 9 | |
| 10 | SRC_URI = "https://download.gnome.org/sources/${BPN}/${@gnome_verdir("${PV}")}/${BPN}-${PV}.tar.xz;name=archive" |
| 11 | |
| 12 | SRC_URI[archive.md5sum] = "96ef53ed613e4d223e0db3a7acea44f0" |
| 13 | SRC_URI[archive.sha256sum] = "3739d64b79c95a9f0f9faf2c5f9e5298b4b2ebdd6431435ce656ecd19b31e2f2" |
| 14 | |
| 15 | |
| 16 | EXTRA_OEMESON = " \ |
| 17 | -Dbluray=false \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 18 | -Dgoa=false \ |
| 19 | -Dgoogle=false \ |
| 20 | -Dnfs=false \ |
| 21 | -Dudisks2=true \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 22 | " |
| 23 | |
| 24 | PACKAGES =+ "gvfsd-ftp gvfsd-sftp gvfsd-trash" |
| 25 | |
| 26 | FILES_${PN} += " \ |
| 27 | ${datadir}/glib-2.0 \ |
| 28 | ${datadir}/GConf \ |
| 29 | ${datadir}/dbus-1/services \ |
| 30 | ${libdir}/gio/modules/*.so \ |
| 31 | ${libdir}/tmpfiles.d \ |
| 32 | ${systemd_user_unitdir} \ |
| 33 | " |
| 34 | RDEPENDS_${PN} = "udisks2" |
| 35 | |
| 36 | FILES_${PN}-dbg += "${libdir}/gio/modules/.debug/*" |
| 37 | FILES_${PN}-dev += "${libdir}/gio/modules/*.la" |
| 38 | |
| 39 | FILES_gvfsd-ftp = "${libexecdir}/gvfsd-ftp ${datadir}/gvfs/mounts/ftp.mount" |
| 40 | FILES_gvfsd-sftp = "${libexecdir}/gvfsd-sftp ${datadir}/gvfs/mounts/sftp.mount" |
| 41 | FILES_gvfsd-trash = "${libexecdir}/gvfsd-trash ${datadir}/gvfs/mounts/trash.mount" |
| 42 | |
| 43 | RRECOMMENDS_gvfsd-ftp += "openssh-sftp openssh-ssh" |
| 44 | |
| 45 | PACKAGECONFIG ?= "libgphoto2 ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" |
| 46 | |
| 47 | PACKAGECONFIG[afc] = "-Dafc=true, -Dafc=false, libimobiledevice libplist" |
| 48 | PACKAGECONFIG[archive] = "-Darchive=true, -Darchive=false, libarchive" |
| 49 | PACKAGECONFIG[dnssd] = "-Ddnssd=true, -Ddnssd=false, avahi" |
| 50 | PACKAGECONFIG[gcr] = "-Dgcr=true, -Dgcr=false, gcr" |
| 51 | PACKAGECONFIG[http] = "-Dhttp=true, -Dhttp=false, libsoup-2.4" |
| 52 | PACKAGECONFIG[libmtp] = "-Dmtp=true, -Dmtp=false, libmtp" |
| 53 | PACKAGECONFIG[logind] = "-Dlogind=true, -Dlogind=false, systemd" |
| 54 | PACKAGECONFIG[libgphoto2] = "-Dgphoto2=true, -Dgphoto2=false, libgphoto2" |
| 55 | PACKAGECONFIG[samba] = "-Dsmb=true, -Dsmb=false, samba" |
| 56 | PACKAGECONFIG[systemd] = "-Dsystemduserunitdir=${systemd_user_unitdir} -Dtmpfilesdir=${libdir}/tmpfiles.d, -Dsystemduserunitdir=no -Dtmpfilesdir=no, systemd" |
| 57 | |
| 58 | # needs meta-filesystems |
| 59 | PACKAGECONFIG[fuse] = "-Dfuse=true, -Dfuse=false, fuse" |
| 60 | |
| 61 | # libcdio-paranoia recipe doesn't exist yet |
| 62 | PACKAGECONFIG[cdda] = "-Dcdda=true, -Dcdda=false, libcdio-paranoia" |
| 63 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 64 | do_install_append() { |
Brad Bishop | 34ae600 | 2019-04-08 15:21:03 -0400 | [diff] [blame] | 65 | # Fix up permissions on polkit rules.d to work with rpm4 constraints |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 66 | chmod 700 ${D}/${datadir}/polkit-1/rules.d |
| 67 | chown polkitd:root ${D}/${datadir}/polkit-1/rules.d |
Brad Bishop | 34ae600 | 2019-04-08 15:21:03 -0400 | [diff] [blame] | 68 | |
| 69 | # After rebuilds (not from scracth) it can happen that the executables in |
| 70 | # libexec ar missing executable permission flag. Not sure but it came up |
| 71 | # during transition to meson. Looked into build files and logs but could |
| 72 | # not find suspicious |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 73 | for exe in `find ${D}/${libexecdir}`; do |
Brad Bishop | 34ae600 | 2019-04-08 15:21:03 -0400 | [diff] [blame] | 74 | chmod +x $exe |
| 75 | done |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 76 | } |