blob: 656ff0dd8983f64107370b9e1c4bbb869f161163 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Open-source monitoring solution for your IT infrastructure"
2DESCRIPTION = "\
3ZABBIX is software that monitors numerous parameters of a network and the \
4health and integrity of servers. ZABBIX uses a flexible notification \
5mechanism that allows users to configure e-mail based alerts for virtually \
6any event. This allows a fast reaction to server problems. ZABBIX offers \
7excellent reporting and data visualisation features based on the stored \
8data. This makes ZABBIX ideal for capacity planning. \
9\
10ZABBIX supports both polling and trapping. All ZABBIX reports and \
11statistics, as well as configuration parameters are accessed through a \
12web-based front end. A web-based front end ensures that the status of \
13your network and the health of your servers can be assessed from any \
14location. Properly configured, ZABBIX can play an important role in \
15monitoring IT infrastructure. This is equally true for small \
16organisations with a few servers and for large companies with a \
17multitude of servers."
18HOMEPAGE = "http://www.zabbix.com/"
19SECTION = "Applications/Internet"
20LICENSE = "GPLv2+"
21LIC_FILES_CHKSUM = "file://COPYING;md5=300e938ad303147fede2294ed78fe02e"
Brad Bishop4fe7a132019-10-07 09:34:48 -040022DEPENDS = "libevent libpcre openldap virtual/libiconv zlib"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050023
24PACKAGE_ARCH = "${MACHINE_ARCH}"
25
26SRC_URI = "http://jaist.dl.sourceforge.net/project/zabbix/ZABBIX%20Latest%20Stable/${PV}/${BPN}-${PV}.tar.gz \
27 file://0001-Fix-configure.ac.patch \
28 file://zabbix-agent.service \
29"
30
Brad Bishop87b3cb82019-11-15 16:35:37 -050031SRC_URI[md5sum] = "e9df94149790f86732f18d042b70155d"
32SRC_URI[sha256sum] = "0bf74e597dd41a558305fe17a2b1ed6fe2d77044b87696a92e4227fbf315564a"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050033
34inherit autotools-brokensep linux-kernel-base pkgconfig systemd useradd
35
36SYSTEMD_PACKAGES = "${PN}"
37SYSTEMD_SERVICE_${PN} = "zabbix-agent.service"
38SYSTEMD_AUTO_ENABLE = "enable"
39
40USERADD_PACKAGES = "${PN}"
41GROUPADD_PARAM_${PN} = "-r zabbix"
42USERADD_PARAM_${PN} = "-r -g zabbix -d /var/lib/zabbix \
43 -s /sbin/nologin -c \"Zabbix Monitoring System\" zabbix \
44"
45
46KERNEL_VERSION = "${@get_kernelversion_headers('${STAGING_KERNEL_DIR}')}"
47
48EXTRA_OECONF = " \
49 --enable-dependency-tracking \
50 --enable-agent \
51 --enable-ipv6 \
52 --with-net-snmp \
53 --with-ldap=${STAGING_EXECPREFIXDIR} \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050054 --with-unixodbc \
55 --with-ssh2 \
56 --with-sqlite3 \
Brad Bishop4fe7a132019-10-07 09:34:48 -040057 --with-zlib \
58 --with-libpthread \
59 --with-libevent \
60 --with-libpcre \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050061"
Brad Bishop4fe7a132019-10-07 09:34:48 -040062CFLAGS_append = " -lldap -llber -pthread"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050063
64do_configure_prepend() {
65 export KERNEL_VERSION="${KERNEL_VERSION}"
66}
67
68do_install_append() {
69 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
70 install -d ${D}${systemd_unitdir}/system
71 install -m 0644 ${WORKDIR}/zabbix-agent.service ${D}${systemd_unitdir}/system/
72 sed -i -e 's#@SBINDIR@#${sbindir}#g' ${D}${systemd_unitdir}/system/zabbix-agent.service
73 fi
74}
75
76FILES_${PN} += "${libdir}"
77
78RDEPENDS_${PN} = "logrotate"