Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "A set of tools using pywbem" |
| 2 | DESCRIPTION = "A set of tools using pywbem to communicate with WBEM servers" |
| 3 | HOMEPAGE = "https://pywbemtools.readthedocs.io/en/stable/" |
| 4 | LICENSE = "Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e23fadd6ceef8c618fc1c65191d846fa" |
| 6 | |
| 7 | SRC_URI[sha256sum] = "0af7e067e0c0ba32cc19c2c2dc67875c591b806c4b49480ebe46e37bfb399684" |
| 8 | |
| 9 | inherit pypi setuptools3 |
| 10 | |
| 11 | DEPENDS += " \ |
| 12 | ${PYTHON_PN}-pyyaml-native \ |
| 13 | ${PYTHON_PN}-pywbem-native \ |
| 14 | ${PYTHON_PN}-six-native \ |
| 15 | ${PYTHON_PN}-click-native \ |
| 16 | " |
| 17 | |
| 18 | RDEPENDS:${PN}:class-target += "\ |
| 19 | ${PYTHON_PN}-ply \ |
| 20 | ${PYTHON_PN}-pyyaml \ |
| 21 | ${PYTHON_PN}-six \ |
| 22 | ${PYTHON_PN}-pywbem \ |
| 23 | ${PYTHON_PN}-click \ |
| 24 | ${PYTHON_PN}-requests \ |
| 25 | ${PYTHON_PN}-prompt-toolkit \ |
| 26 | ${PYTHON_PN}-mock \ |
| 27 | ${PYTHON_PN}-packaging \ |
| 28 | ${PYTHON_PN}-nocasedict \ |
| 29 | ${PYTHON_PN}-yamlloader \ |
| 30 | ${PYTHON_PN}-click-repl \ |
| 31 | ${PYTHON_PN}-click-spinner \ |
| 32 | ${PYTHON_PN}-asciitree \ |
| 33 | ${PYTHON_PN}-tabulate \ |
| 34 | ${PYTHON_PN}-pydicti \ |
| 35 | ${PYTHON_PN}-nocaselist \ |
| 36 | ${PYTHON_PN}-custom-inherit \ |
| 37 | " |
| 38 | |
| 39 | BBCLASSEXTEND = "native" |