Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | SUMMARY = "Utilities for managing LZMA compressed files" |
| 2 | HOMEPAGE = "https://tukaani.org/xz/" |
| 3 | DESCRIPTION = "XZ Utils is free general-purpose data compression software with a high compression ratio. XZ Utils were written for POSIX-like systems, but also work on some not-so-POSIX systems. XZ Utils are the successor to LZMA Utils." |
| 4 | SECTION = "base" |
| 5 | |
| 6 | # The source includes bits of PD, GPL-2.0, GPL-3.0, LGPL-2.1-or-later, but the |
| 7 | # only file which is GPL-3.0 is an m4 macro which isn't shipped in any of our |
| 8 | # packages, and the LGPL bits are under lib/, which appears to be used for |
| 9 | # libgnu, which appears to be used for DOS builds. So we're left with |
| 10 | # GPL-2.0-or-later and PD. |
| 11 | LICENSE = "GPL-2.0-or-later & GPL-3.0-with-autoconf-exception & LGPL-2.1-or-later & PD" |
| 12 | LICENSE:${PN} = "GPL-2.0-or-later" |
| 13 | LICENSE:${PN}-dev = "GPL-2.0-or-later" |
| 14 | LICENSE:${PN}-staticdev = "GPL-2.0-or-later" |
| 15 | LICENSE:${PN}-doc = "GPL-2.0-or-later" |
| 16 | LICENSE:${PN}-dbg = "GPL-2.0-or-later" |
| 17 | LICENSE:${PN}-locale = "GPL-2.0-or-later" |
| 18 | LICENSE:liblzma = "PD" |
| 19 | |
| 20 | LIC_FILES_CHKSUM = "file://COPYING;md5=97d554a32881fee0aa283d96e47cb24a \ |
| 21 | file://COPYING.GPLv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 22 | file://COPYING.GPLv3;md5=d32239bcb673463ab874e80d47fae504 \ |
| 23 | file://COPYING.LGPLv2.1;md5=4fbd65380cdd255951079008b364516c \ |
| 24 | file://lib/getopt.c;endline=23;md5=2069b0ee710572c03bb3114e4532cd84 \ |
| 25 | " |
| 26 | |
| 27 | SRC_URI = "https://tukaani.org/xz/xz-${PV}.tar.gz" |
| 28 | SRC_URI[sha256sum] = "a2105abee17bcd2ebd15ced31b4f5eda6e17efd6b10f921a01cda4a44c91b3a0" |
| 29 | UPSTREAM_CHECK_REGEX = "xz-(?P<pver>\d+(\.\d+)+)\.tar" |
| 30 | |
| 31 | CACHED_CONFIGUREVARS += "gl_cv_posix_shell=/bin/sh" |
| 32 | |
| 33 | inherit autotools gettext |
| 34 | |
| 35 | PACKAGES =+ "liblzma" |
| 36 | |
| 37 | FILES:liblzma = "${libdir}/liblzma*${SOLIBS}" |
| 38 | |
| 39 | inherit update-alternatives |
| 40 | ALTERNATIVE_PRIORITY = "100" |
| 41 | ALTERNATIVE:${PN} = "xz xzcat unxz \ |
| 42 | lzma lzcat unlzma" |
| 43 | |
| 44 | BBCLASSEXTEND = "native nativesdk" |