Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "An implementation of the standard Unix documentation system accessed using the man command" |
| 2 | HOMEPAGE = "http://man-db.nongnu.org/" |
| 3 | LICENSE = "LGPLv2.1 & GPLv2" |
| 4 | LIC_FILES_CHKSUM = "file://docs/COPYING.LIB;md5=a6f89e2100d9b6cdffcea4f398e37343 \ |
| 5 | file://docs/COPYING;md5=eb723b61539feef013de476e68b5c50a" |
| 6 | |
| 7 | SRC_URI = "${SAVANNAH_NONGNU_MIRROR}/man-db/man-db-${PV}.tar.xz \ |
| 8 | file://99_mandb \ |
| 9 | file://man_db.conf-avoid-multilib-install-file-conflict.patch" |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 10 | SRC_URI[md5sum] = "ec0b23c8314a1654c4d059b2c18ce43d" |
| 11 | SRC_URI[sha256sum] = "b9cd5bb996305d08bfe9e1114edc30b4c97be807093b88af8033ed1cf9beb326" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 12 | |
| 13 | DEPENDS = "libpipeline gdbm groff-native base-passwd" |
| 14 | RDEPENDS_${PN} += "base-passwd" |
| 15 | |
| 16 | # | /usr/src/debug/man-db/2.8.0-r0/man-db-2.8.0/src/whatis.c:939: undefined reference to `_nl_msg_cat_cntr' |
| 17 | USE_NLS_libc-musl = "no" |
| 18 | |
| 19 | inherit gettext pkgconfig autotools systemd |
| 20 | |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 21 | EXTRA_OECONF = "--with-pager=less --with-systemdsystemunitdir=${systemd_unitdir}/system" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 22 | EXTRA_AUTORECONF += "-I ${S}/gl/m4" |
| 23 | |
| 24 | do_install() { |
| 25 | autotools_do_install |
| 26 | |
| 27 | if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then |
| 28 | install -d ${D}/etc/default/volatiles |
| 29 | install -m 0644 ${WORKDIR}/99_mandb ${D}/etc/default/volatiles |
| 30 | fi |
| 31 | } |
| 32 | |
| 33 | do_install_append_libc-musl() { |
| 34 | rm -f ${D}${libdir}/charset.alias |
| 35 | } |
| 36 | |
| 37 | FILES_${PN} += "${prefix}/lib/tmpfiles.d" |
| 38 | |
| 39 | FILES_${PN}-dev += "${libdir}/man-db/libman.so ${libdir}/${BPN}/libmandb.so" |
| 40 | |
| 41 | RDEPENDS_${PN} += "groff" |
| 42 | RRECOMMENDS_${PN} += "less" |
| 43 | RPROVIDES_${PN} += " man" |
| 44 | |
| 45 | def compress_pkg(d): |
| 46 | if bb.utils.contains("INHERIT", "compress_doc", True, False, d): |
| 47 | compress = d.getVar("DOC_COMPRESS") |
| 48 | if compress == "gz": |
| 49 | return "gzip" |
| 50 | elif compress == "bz2": |
| 51 | return "bzip2" |
| 52 | elif compress == "xz": |
| 53 | return "xz" |
| 54 | return "" |
| 55 | |
| 56 | RDEPENDS_${PN} += "${@compress_pkg(d)}" |
| 57 | |
| 58 | SYSTEMD_SERVICE_${PN} = "man-db.timer man-db.service" |
| 59 | SYSTEMD_AUTO_ENABLE ?= "disable" |