Andrew Geissler | af5e4ef | 2020-10-16 10:22:50 -0500 | [diff] [blame] | 1 | SUMMARY = "Boost.Build" |
| 2 | SECTION = "devel" |
| 3 | |
| 4 | LICENSE = "BSL-1.0" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e4224ccaecb14d942c71d31bef20d78c" |
| 6 | |
| 7 | SRC_URI = "git://github.com/boostorg/build;protocol=https" |
| 8 | SRCREV = "632ea768f3eb225b4472c5ed6d20afee708724ad" |
| 9 | |
| 10 | inherit native |
| 11 | |
| 12 | S = "${WORKDIR}/git" |
| 13 | |
| 14 | do_compile() { |
| 15 | ./bootstrap.sh |
| 16 | } |
| 17 | |
| 18 | do_install() { |
| 19 | ./b2 install --prefix=${prefix} staging-prefix=${D}${prefix} |
| 20 | } |
| 21 | |
| 22 | # The build is either release mode (pre-stripped) or debug (-O0). |
| 23 | INSANE_SKIP_${PN} = "already-stripped" |