Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "GTK+ icon theme" |
| 2 | HOMEPAGE = "https://gitlab.gnome.org/GNOME/adwaita-icon-theme" |
| 3 | BUGTRACKER = "https://gitlab.gnome.org/GNOME/adwaita-icon-theme/issues" |
| 4 | SECTION = "x11/gnome" |
| 5 | |
| 6 | LICENSE = "LGPL-3.0 | CC-BY-SA-3.0" |
Andrew Geissler | 475cb72 | 2020-07-10 16:00:51 -0500 | [diff] [blame] | 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=c84cac88e46fc07647ea07e6c24eeb7c \ |
| 8 | file://COPYING_CCBYSA3;md5=96143d33de3a79321b1006c4e8ed07e7 \ |
| 9 | file://COPYING_LGPL;md5=e6a600fd5e1d9cbde2d983680233ad02" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 10 | |
| 11 | inherit allarch autotools pkgconfig gettext gtk-icon-cache upstream-version-is-even |
| 12 | |
| 13 | MAJ_VER = "${@oe.utils.trim_version("${PV}", 2)}" |
| 14 | SRC_URI = "${GNOME_MIRROR}/${BPN}/${MAJ_VER}/${BPN}-${PV}.tar.xz \ |
| 15 | file://0001-Don-t-use-AC_CANONICAL_HOST.patch \ |
| 16 | file://0001-Run-installation-commands-as-shell-jobs.patch \ |
| 17 | " |
| 18 | |
Andrew Geissler | 4ed12e1 | 2020-06-05 18:00:41 -0500 | [diff] [blame] | 19 | SRC_URI[md5sum] = "c61ca9d6b3ce70a9ab66dcff945923ff" |
| 20 | SRC_URI[sha256sum] = "e498518627044dfd7db7d79a5b3d437848caf1991ef4ef036a2d3a2ac2c1f14d" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 21 | |
| 22 | DEPENDS += "librsvg-native" |
| 23 | |
| 24 | PACKAGES = "${PN}-cursors ${PN}-symbolic-hires ${PN}-symbolic ${PN}-hires ${PN}" |
| 25 | |
| 26 | RREPLACES_${PN} = "gnome-icon-theme" |
| 27 | RCONFLICTS_${PN} = "gnome-icon-theme" |
| 28 | RPROVIDES_${PN} = "gnome-icon-theme" |
| 29 | |
| 30 | FILES_${PN}-cursors = "${prefix}/share/icons/Adwaita/cursors/" |
| 31 | FILES_${PN}-symbolic-hires = "${prefix}/share/icons/Adwaita/96x96/*/*.symbolic.png \ |
| 32 | ${prefix}/share/icons/Adwaita/64x64/*/*.symbolic.png \ |
| 33 | ${prefix}/share/icons/Adwaita/48x48/*/*.symbolic.png \ |
| 34 | ${prefix}/share/icons/Adwaita/32x32/*/*.symbolic.png" |
| 35 | FILES_${PN}-symbolic = "${prefix}/share/icons/Adwaita/16x16/*/*.symbolic.png \ |
| 36 | ${prefix}/share/icons/Adwaita/24x24/*/*.symbolic.png \ |
| 37 | ${prefix}/share/icons/Adwaita/scalable/*/*-symbolic*.svg" |
| 38 | FILES_${PN}-hires = "${prefix}/share/icons/Adwaita/256x256/ \ |
| 39 | ${prefix}/share/icons/Adwaita/512x512/" |
| 40 | FILES_${PN} = "${prefix}/share/icons/Adwaita/ \ |
| 41 | ${prefix}/share/pkgconfig/adwaita-icon-theme.pc" |
| 42 | |
| 43 | BBCLASSEXTEND = "native nativesdk" |