Andrew Jeffery | 858c971 | 2021-05-04 12:46:46 +0930 | [diff] [blame] | 1 | SUMMARY = "Debug trigger" |
| 2 | DESCRIPTION = "Forcibly crash an unresponsive system to collect debug data" |
| 3 | HOMEPAGE = "https://github.com/openbmc/debug-trigger" |
| 4 | |
Patrick Williams | bb99d22 | 2022-01-24 15:55:09 -0600 | [diff] [blame] | 5 | SRC_URI = "git://github.com/openbmc/debug-trigger;branch=master;protocol=https" |
Andrew Jeffery | 858c971 | 2021-05-04 12:46:46 +0930 | [diff] [blame] | 6 | |
| 7 | LICENSE = "Apache-2.0" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
| 9 | |
| 10 | S = "${WORKDIR}/git" |
| 11 | |
| 12 | inherit meson |
| 13 | inherit pkgconfig |
| 14 | inherit systemd |
| 15 | |
| 16 | PR = "r1" |
| 17 | PV = "0.1+git${SRCPV}" |
Andrew Geissler | 74b4ab2 | 2022-01-21 00:40:08 +0000 | [diff] [blame] | 18 | SRCREV = "1161642d2288f71549f0c9f89d09807ca251b58f" |
Andrew Jeffery | 858c971 | 2021-05-04 12:46:46 +0930 | [diff] [blame] | 19 | |
| 20 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" |
| 21 | |
| 22 | DEBUG_TRIGGERS ?= "" |
| 23 | |
| 24 | PACKAGECONFIG[systemd] = " \ |
| 25 | -Dsystemd=true, \ |
| 26 | -Dsystemd=false, \ |
| 27 | systemd" |
| 28 | |
| 29 | PACKAGECONFIG[triggers] = " \ |
| 30 | -Dtriggers=${DEBUG_TRIGGERS}, \ |
| 31 | -Dtriggers=[], \ |
| 32 | systemd udev" |
| 33 | |
Patrick Williams | 12fc939 | 2021-08-06 09:16:53 -0500 | [diff] [blame] | 34 | SYSTEMD_SERVICE:${PN} += "debug-trigger@.service" |