blob: 8e0094b318317561fa87febe214c17c7aa8fef39 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001DESCRIPTION = "Parallelism library for C++ - runtime files \
2 TBB is a library that helps you leverage multi-core processor \
3 performance without having to be a threading expert. It represents a \
4 higher-level, task-based parallelism that abstracts platform details \
5 and threading mechanism for performance and scalability."
6HOMEPAGE = "https://software.intel.com/en-us/tbb"
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
9BRANCH = "tbb_2020"
Andrew Geisslera2681d92020-10-16 10:17:07 -050010SRCREV = "eca91f16d7490a8abfdee652dadf457ec820cc37"
Andrew Geissler82c905d2020-04-13 13:39:40 -050011SRC_URI = "git://github.com/oneapi-src/oneTBB.git;protocol=https;branch=${BRANCH} \
12 file://cross-compile.patch \
13 file://0001-mallinfo-is-glibc-specific-API-mark-it-so.patch \
14 file://GLIBC-PREREQ-is-not-defined-on-musl.patch \
15 file://tbb.pc \
Andrew Geisslera2681d92020-10-16 10:17:07 -050016 file://improve-reproducibility.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050017"
18
19S = "${WORKDIR}/git"
20PE = "1"
21
22COMPILER ?= "gcc"
23COMPILER_toolchain-clang = "clang"
24
25do_compile() {
26 oe_runmake compiler=${COMPILER} arch=${HOST_ARCH}
27}
28
29do_install() {
30 install -d ${D}${includedir} ${D}${libdir}
31 rm ${S}/include/tbb/index.html -f
32 cp -R --no-dereference --preserve=mode,links -v ${S}/include/tbb ${D}${includedir}
33 for f in ${B}/build/linux_*_release/lib*.so*
34 do
35 install -Dm 0755 $f ${D}${libdir}/
36 done
37 install -Dm 0644 ${WORKDIR}/tbb.pc ${D}${libdir}/pkgconfig/tbb.pc
38}
39
40# fails with thumb enabled:
41# | arm-oe-linux-gnueabi-g++ -march=armv7-a -mthumb -mthumb-interwork -mfloat-abi=softfp -mfpu=neon -mtune=cortex-a9 -mcpu=cortex-a9 -D__ARM__ -D__LINUX_ARM_ARCH__=7 -funwind-tables -mvectorize-with-neon-quad -rdynamic --sysroot=/OE/sysroots/m14tv -c -MMD -DTBB_USE_DEBUG -g -O0 -DUSE_PTHREAD -fPIC -D__TBB_BUILD=1 -Wall -Wno-parentheses -Wno-non-virtual-dtor -O2 -pipe -g -feliminate-unused-debug-types -fpermissive -fvisibility-inlines-hidden -I../../src -I../../src/rml/include -I../../include ../../src/tbb/concurrent_queue.cpp
42# | {standard input}: Assembler messages:
43# | {standard input}:250: Error: thumb conditional instruction should be in IT block -- `strexeq r2,r3,[r4]'
44# ...
45# | make[1]: *** [concurrent_queue.o] Error 1
46ARM_INSTRUCTION_SET = "arm"