Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "GNU file archiving program" |
| 2 | DESCRIPTION = "GNU tar saves many files together into a single tape \ |
| 3 | or disk archive, and can restore individual files from the archive." |
| 4 | HOMEPAGE = "http://www.gnu.org/software/tar/" |
| 5 | SECTION = "base" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 6 | LICENSE = "GPLv3" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 8 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 9 | SRC_URI = "${GNU_MIRROR}/tar/tar-${PV}.tar.bz2 \ |
| 10 | file://remove-gets.patch \ |
| 11 | file://musl_dirent.patch \ |
| 12 | " |
| 13 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 14 | SRC_URI[md5sum] = "8404e4c1fc5a3000228ab2b8ad674a65" |
| 15 | SRC_URI[sha256sum] = "87592b86cb037c554375f5868bdd3cc57748aef38d6cb741c81065f0beac63b7" |
| 16 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 17 | inherit autotools gettext texinfo |
| 18 | |
| 19 | PACKAGECONFIG ??= "" |
| 20 | PACKAGECONFIG_append_class-target = " ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)}" |
| 21 | |
| 22 | PACKAGECONFIG[acl] = "--with-posix-acls,--without-posix-acls,acl" |
| 23 | |
| 24 | EXTRA_OECONF += "DEFAULT_RMT_DIR=${base_sbindir}" |
| 25 | |
| 26 | # Let aclocal use the relative path for the m4 file rather than the |
| 27 | # absolute since tar has a lot of m4 files, otherwise there might |
| 28 | # be an "Argument list too long" error when it is built in a long/deep |
| 29 | # directory. |
| 30 | acpaths = "-I ./m4" |
| 31 | |
| 32 | do_install () { |
| 33 | autotools_do_install |
| 34 | ln -s tar ${D}${bindir}/gtar |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 35 | } |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 36 | |
| 37 | do_install_append_class-target() { |
| 38 | if [ "${base_bindir}" != "${bindir}" ]; then |
| 39 | install -d ${D}${base_bindir} |
| 40 | mv ${D}${bindir}/tar ${D}${base_bindir}/tar |
| 41 | mv ${D}${bindir}/gtar ${D}${base_bindir}/gtar |
| 42 | rmdir ${D}${bindir}/ |
| 43 | fi |
| 44 | } |
| 45 | |
| 46 | do_install_append_libc-musl() { |
| 47 | rm -f ${D}${libdir}/charset.alias |
| 48 | rmdir ${D}${libdir} |
| 49 | } |
| 50 | |
| 51 | PACKAGES =+ "${PN}-rmt" |
| 52 | |
| 53 | FILES_${PN}-rmt = "${base_sbindir}/rmt*" |
| 54 | |
| 55 | inherit update-alternatives |
| 56 | |
| 57 | ALTERNATIVE_PRIORITY = "100" |
| 58 | |
| 59 | ALTERNATIVE_${PN} = "tar" |
| 60 | ALTERNATIVE_${PN}-rmt = "rmt" |
| 61 | ALTERNATIVE_${PN}_class-nativesdk = "" |
| 62 | ALTERNATIVE_${PN}-rmt_class-nativesdk = "" |
| 63 | |
| 64 | ALTERNATIVE_LINK_NAME[tar] = "${base_bindir}/tar" |
| 65 | ALTERNATIVE_LINK_NAME[rmt] = "${base_sbindir}/rmt" |
| 66 | |
| 67 | PROVIDES_append_class-native = " tar-replacement-native" |
| 68 | NATIVE_PACKAGE_PATH_SUFFIX = "/${PN}" |
| 69 | |
| 70 | BBCLASSEXTEND = "native nativesdk" |