Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Build Result Compare Script" |
| 2 | DESCRIPTION = "This package contains scripts to find out if the build result\ |
| 3 | differs to a former build." |
| 4 | HOMEPAGE = "https://github.com/openSUSE/build-compare" |
| 5 | LICENSE = "GPLv2" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" |
| 7 | |
| 8 | SRC_URI = "git://github.com/openSUSE/build-compare.git \ |
| 9 | file://Rename-rpm-check.sh-to-pkg-diff.sh.patch;striplevel=1 \ |
| 10 | file://Ignore-DWARF-sections.patch;striplevel=1 \ |
| 11 | file://0001-Add-support-for-deb-and-ipk-packaging.patch \ |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 12 | file://functions.sh-remove-space-at-head.patch \ |
| 13 | file://functions.sh-run-rpm-once-to-make-it-faster.patch \ |
| 14 | file://pkg-diff.sh-check-for-fifo-named-pipe.patch \ |
| 15 | file://pkg-diff.sh-check_single_file-return-at-once-when-sa.patch \ |
| 16 | file://pkg-diff.sh-remove-space-in-the-end-for-ftype.patch \ |
| 17 | file://functions.sh-improve-deb-and-ipk-checking.patch \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 18 | " |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 19 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 20 | # Date matches entry in build-compare.changes and date of SRCREV. |
| 21 | # |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 22 | SRCREV = "c5352c054c6ef15735da31b76d6d88620f4aff0a" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 23 | PE = "1" |
| 24 | PV = "2015.02.10+git${SRCPV}" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 25 | UPSTREAM_CHECK_COMMITS = "1" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 26 | |
| 27 | S = "${WORKDIR}/git" |
| 28 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 29 | BBCLASSEXTEND = "native nativesdk" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 30 | |
| 31 | do_install() { |
| 32 | install -d ${D}/${bindir} |
| 33 | install -m 755 functions.sh ${D}/${bindir} |
| 34 | install -m 755 pkg-diff.sh ${D}/${bindir} |
| 35 | install -m 755 same-build-result.sh ${D}/${bindir} |
| 36 | install -m 755 srpm-check.sh ${D}/${bindir} |
| 37 | } |
| 38 | |
| 39 | RDEPENDS_${PN} += "bash" |