Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 1 | SUMMARY = "Tool to produce a statistics based on a diff" |
| 2 | DESCRIPTION = "diffstat reads the output of diff and displays a histogram of \ |
| 3 | the insertions, deletions, and modifications per-file. It is useful for \ |
| 4 | reviewing large, complex patch files." |
| 5 | HOMEPAGE = "http://invisible-island.net/diffstat/" |
| 6 | SECTION = "devel" |
| 7 | LICENSE = "MIT" |
| 8 | LIC_FILES_CHKSUM = "file://install-sh;endline=42;md5=b3549726c1022bee09c174c72a0ca4a5" |
| 9 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 10 | SRC_URI = "http://invisible-mirror.net/archives/${BPN}/${BP}.tgz \ |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 11 | file://run-ptest \ |
| 12 | " |
| 13 | |
| 14 | SRC_URI[md5sum] = "c048a32d55d8bd6724f382baf41f325f" |
| 15 | SRC_URI[sha256sum] = "25359e0c27183f997b36c9202583b5dc2df390c20e22a92606af4bf7856a55ee" |
| 16 | |
| 17 | S = "${WORKDIR}/diffstat-${PV}" |
| 18 | |
| 19 | inherit autotools gettext ptest |
| 20 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 21 | EXTRA_AUTORECONF += "--exclude=aclocal" |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 22 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 23 | LDFLAGS += "${TOOLCHAIN_OPTIONS}" |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 24 | |
| 25 | do_install_ptest() { |
| 26 | cp -r ${S}/testing ${D}${PTEST_PATH} |
| 27 | } |