Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 1 | SUMMARY = "A microframework based on Werkzeug, Jinja2 and good intentions" |
| 2 | DESCRIPTION = "\ |
| 3 | Flask is a microframework for Python based on Werkzeug, Jinja 2 and good \ |
| 4 | intentions. And before you ask: It’s BSD licensed!" |
| 5 | HOMEPAGE = "https://github.com/mitsuhiko/flask/" |
| 6 | LICENSE = "BSD-3-Clause" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=ffeffa59c90c9c4a033c7574f8f3fb75" |
| 8 | |
Patrick Williams | 5877637 | 2022-04-13 09:07:35 -0500 | [diff] [blame^] | 9 | SRC_URI[sha256sum] = "a8c9bd3e558ec99646d177a9739c41df1ded0629480b4c8d2975412f3c9519c8" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 10 | |
| 11 | PYPI_PACKAGE = "Flask" |
| 12 | |
| 13 | inherit pypi setuptools3 |
| 14 | |
| 15 | CLEANBROKEN = "1" |
| 16 | |
| 17 | RDEPENDS:${PN} = " \ |
| 18 | ${PYTHON_PN}-werkzeug \ |
| 19 | ${PYTHON_PN}-jinja2 \ |
| 20 | ${PYTHON_PN}-itsdangerous \ |
| 21 | ${PYTHON_PN}-click \ |
| 22 | ${PYTHON_PN}-profile \ |
| 23 | " |