blob: 7fdf9e0190f1fc34b80c764b33b6742dbde4cb8f [file] [log] [blame]
Andrew Geisslera2681d92020-10-16 10:17:07 -05001SUMMARY = "Argcomplete provides easy, extensible command line tab completion of arguments for your Python script."
2HOMEPAGE = "https://github.com/kislyuk/argcomplete"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=2ee41112a44fe7014dce33e26468ba93"
5
Andrew Geisslerf103a7f2021-05-07 16:09:40 -05006SRC_URI[sha256sum] = "2c7dbffd8c045ea534921e63b0be6fe65e88599990d8dc408ac8c542b72a5445"
Andrew Geisslera2681d92020-10-16 10:17:07 -05007
8PYPI_PACKAGE = "argcomplete"
9
10inherit pypi setuptools3
11
12RDEPENDS_${PN} += "\
13 ${PYTHON_PN}-core \
Andrew Geisslerf103a7f2021-05-07 16:09:40 -050014 ${PYTHON_PN}-io \
Andrew Geisslera2681d92020-10-16 10:17:07 -050015"
16
17BBCLASSEXTEND = "native nativesdk"
18