Andrew Geissler | 97771a3 | 2021-03-05 15:23:11 -0600 | [diff] [blame] | 1 | DESCRIPTION = "Google gRPC tools" |
| 2 | HOMEPAGE = "http://www.grpc.io/" |
| 3 | SECTION = "devel/python" |
| 4 | |
| 5 | LICENSE = "Apache-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=7145f7cdd263359b62d342a02f005515" |
| 7 | |
| 8 | inherit pypi setuptools3 |
| 9 | |
| 10 | DEPENDS += "${PYTHON_PN}-grpcio" |
| 11 | |
| 12 | SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch" |
| 13 | |
Andrew Geissler | e34f896 | 2021-04-15 15:53:51 -0500 | [diff] [blame] | 14 | SRC_URI[sha256sum] = "3ec510c1b6bfc32effc639acf9a055e72dab7a7b6757bf72f2132790d6a7cf1c" |
Andrew Geissler | 97771a3 | 2021-03-05 15:23:11 -0600 | [diff] [blame] | 15 | |
| 16 | RDEPENDS_${PN} = "${PYTHON_PN}-grpcio" |
| 17 | |
| 18 | BBCLASSEXTEND = "native nativesdk" |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 19 | |
| 20 | # Needs abseil-cpp which does not build for ppc64le/musl |
| 21 | COMPATIBLE_HOST_libc-musl_powerpc64le = "null" |
| 22 | |