blob: e0f1a8ca6e89cff724b299728e7478dbc5c2c8cd [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001DESCRIPTION = "Twisted is an event-driven networking framework written in Python and licensed under the LGPL. \
2Twisted supports TCP, UDP, SSL/TLS, multicast, Unix sockets, a large number of protocols \
3(including HTTP, NNTP, IMAP, SSH, IRC, FTP, and others), and much more."
4HOMEPAGE = "http://www.twistedmatrix.com"
5
6#twisted/topfiles/NEWS:655: - Relicensed: Now under the MIT license, rather than LGPL.
7LICENSE = "MIT"
Andrew Geissler32b11992021-03-31 13:37:05 -05008LIC_FILES_CHKSUM = "file://LICENSE;md5=e33c411c0b86b1f3ca299091ed51ca31"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05009
Andrew Geissler32b11992021-03-31 13:37:05 -050010SRC_URI[sha256sum] = "77544a8945cf69b98d2946689bbe0c75de7d145cdf11f391dd487eae8fc95a12"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050011
12PYPI_PACKAGE = "Twisted"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050013
Andrew Geisslerc87764f2020-06-27 00:16:32 -050014inherit pypi setuptools3
15
Brad Bishopd7bf8c12018-02-25 22:55:05 -050016do_install_append() {
17 # remove some useless files before packaging
18 find ${D} \( -name "*.bat" -o -name "*.c" -o -name "*.h" \) -exec rm -f {} \;
19}
20
21PACKAGES += "\
22 ${PN}-zsh \
23 ${PN}-test \
24 ${PN}-protocols \
25 ${PN}-conch \
26 ${PN}-mail \
27 ${PN}-names \
28 ${PN}-news \
29 ${PN}-runner \
30 ${PN}-web \
31 ${PN}-words \
32 ${PN}-flow \
33 ${PN}-pair \
34 ${PN}-core \
35"
36
37PACKAGES =+ "\
Brad Bishopd7bf8c12018-02-25 22:55:05 -050038 ${PN}-bin \
39"
40
Brad Bishop316dfdd2018-06-25 12:45:53 -040041DEPENDS += " \
42 ${PYTHON_PN}-incremental-native \
43"
44
Brad Bishopd7bf8c12018-02-25 22:55:05 -050045RDEPENDS_${PN} = "\
46 ${PN}-bin \
47 ${PN}-core \
48 ${PN}-conch \
49 ${PN}-mail \
50 ${PN}-names \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080051 ${PN}-pair \
52 ${PN}-protocols \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050053 ${PN}-runner \
54 ${PN}-web \
55 ${PN}-words \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080056 ${PN}-zsh \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050057"
58
Andrew Geissler82c905d2020-04-13 13:39:40 -050059RDEPENDS_${PN}-core = "${PYTHON_PN}-appdirs \
60 ${PYTHON_PN}-automat \
61 ${PYTHON_PN}-constantly \
Andrew Geisslerc87764f2020-06-27 00:16:32 -050062 ${PYTHON_PN}-core \
Andrew Geissler82c905d2020-04-13 13:39:40 -050063 ${PYTHON_PN}-debugger \
64 ${PYTHON_PN}-hyperlink \
65 ${PYTHON_PN}-incremental \
66 ${PYTHON_PN}-pyhamcrest \
67 ${PYTHON_PN}-pyserial \
68 ${PYTHON_PN}-unixadmin \
69 ${PYTHON_PN}-zopeinterface \
70"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050071RDEPENDS_${PN}-test = "${PN}"
Brad Bishope42b3e32020-01-15 22:08:42 -050072RDEPENDS_${PN}-conch = "${PN}-core ${PN}-protocols ${PYTHON_PN}-bcrypt ${PYTHON_PN}-cryptography ${PYTHON_PN}-pyasn1 ${PYTHON_PN}-pickle"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050073RDEPENDS_${PN}-mail = "${PN}-core ${PN}-protocols"
74RDEPENDS_${PN}-names = "${PN}-core"
75RDEPENDS_${PN}-news = "${PN}-core ${PN}-protocols"
76RDEPENDS_${PN}-runner = "${PN}-core ${PN}-protocols"
77RDEPENDS_${PN}-web += "${PN}-core ${PN}-protocols"
78RDEPENDS_${PN}-words += "${PN}-core"
79RDEPENDS_${PN}-flow += "${PN}-core"
80RDEPENDS_${PN}-pair += "${PN}-core"
81RDEPENDS_${PN}-dbg = "${PN}"
82
83ALLOW_EMPTY_${PN} = "1"
84FILES_${PN} = ""
85
86FILES_${PN}-test = " \
87 ${libdir}/${PYTHON_DIR}/site-packages/twisted/test \
88 ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/test \
89 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/haproxy/test/ \
90"
91
92FILES_${PN}-protocols = " \
93 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/*.py* \
94 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/gps/ \
95 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/mice/ \
96 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/haproxy \
97"
98
99FILES_${PN}-zsh = " \
100 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zsh \
101 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zshcomp.* \
102 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/twisted-completion.zsh \
103"
104
105FILES_${PN}-conch = " \
106 ${bindir}/ckeygen \
107 ${bindir}/tkconch \
108 ${bindir}/conch \
109 ${bindir}/conchftp \
110 ${bindir}/cftp \
111 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_conch.py* \
112 ${libdir}/${PYTHON_DIR}/site-packages/twisted/conch \
113"
114
115FILES_${PN}-core = " \
116${bindir}/manhole \
117${bindir}/mktap \
118${bindir}/twistd \
119${bindir}/tap2deb \
120${bindir}/tap2rpm \
121${bindir}/tapconvert \
122${bindir}/tkmktap \
123${bindir}/trial \
124${bindir}/easy_install* \
125${bindir}/pyhtmlizer \
126${libdir}/${PYTHON_DIR}/site-packages/twisted/python/*.so \
127${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py* \
128${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__init__.py* \
129${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/notestplugin.py* \
130${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/testplugin.py* \
131${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_ftp.py* \
132${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_inet.py* \
133${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_manhole.py* \
134${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_portforward.py* \
135${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_socks.py* \
136${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_telnet.py* \
137${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_trial.py* \
138${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/dropin.cache \
139${libdir}/${PYTHON_DIR}/site-packages/twisted/application \
140${libdir}/${PYTHON_DIR}/site-packages/twisted/cred \
141${libdir}/${PYTHON_DIR}/site-packages/twisted/enterprise \
142${libdir}/${PYTHON_DIR}/site-packages/twisted/internet \
143${libdir}/${PYTHON_DIR}/site-packages/twisted/manhole \
144${libdir}/${PYTHON_DIR}/site-packages/twisted/manhole \
145${libdir}/${PYTHON_DIR}/site-packages/twisted/persisted \
146${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols\
147${libdir}/${PYTHON_DIR}/site-packages/twisted/python\
148${libdir}/${PYTHON_DIR}/site-packages/twisted/python/timeoutqueue.py* \
149${libdir}/${PYTHON_DIR}/site-packages/twisted/python/filepath.py* \
150${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dxprofile.py* \
151${libdir}/${PYTHON_DIR}/site-packages/twisted/python/plugin.py* \
152${libdir}/${PYTHON_DIR}/site-packages/twisted/python/htmlizer.py* \
153${libdir}/${PYTHON_DIR}/site-packages/twisted/python/__init__.py* \
154${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dispatch.py* \
155${libdir}/${PYTHON_DIR}/site-packages/twisted/python/hook.py* \
156${libdir}/${PYTHON_DIR}/site-packages/twisted/python/threadpool.py* \
157${libdir}/${PYTHON_DIR}/site-packages/twisted/python/otp.py* \
158${libdir}/${PYTHON_DIR}/site-packages/twisted/python/usage.py* \
159${libdir}/${PYTHON_DIR}/site-packages/twisted/python/roots.py* \
160${libdir}/${PYTHON_DIR}/site-packages/twisted/python/versions.py* \
161${libdir}/${PYTHON_DIR}/site-packages/twisted/python/urlpath.py* \
162${libdir}/${PYTHON_DIR}/site-packages/twisted/python/util.py* \
163${libdir}/${PYTHON_DIR}/site-packages/twisted/python/components.py* \
164${libdir}/${PYTHON_DIR}/site-packages/twisted/python/logfile.py* \
165${libdir}/${PYTHON_DIR}/site-packages/twisted/python/runtime.py* \
166${libdir}/${PYTHON_DIR}/site-packages/twisted/python/reflect.py* \
167${libdir}/${PYTHON_DIR}/site-packages/twisted/python/context.py* \
168${libdir}/${PYTHON_DIR}/site-packages/twisted/python/threadable.py* \
169${libdir}/${PYTHON_DIR}/site-packages/twisted/python/rebuild.py* \
170${libdir}/${PYTHON_DIR}/site-packages/twisted/python/failure.py* \
171${libdir}/${PYTHON_DIR}/site-packages/twisted/python/lockfile.py* \
172${libdir}/${PYTHON_DIR}/site-packages/twisted/python/formmethod.py* \
173${libdir}/${PYTHON_DIR}/site-packages/twisted/python/finalize.py* \
174${libdir}/${PYTHON_DIR}/site-packages/twisted/python/win32.py* \
175${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dist.py* \
176${libdir}/${PYTHON_DIR}/site-packages/twisted/python/shortcut.py* \
177${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zipstream.py* \
178${libdir}/${PYTHON_DIR}/site-packages/twisted/python/release.py* \
179${libdir}/${PYTHON_DIR}/site-packages/twisted/python/syslog.py* \
180${libdir}/${PYTHON_DIR}/site-packages/twisted/python/log.py* \
181${libdir}/${PYTHON_DIR}/site-packages/twisted/python/compat.py* \
182${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zshcomp.py* \
183${libdir}/${PYTHON_DIR}/site-packages/twisted/python/procutils.py* \
184${libdir}/${PYTHON_DIR}/site-packages/twisted/python/text.py* \
185${libdir}/${PYTHON_DIR}/site-packages/twisted/python/_twisted_zsh_stub \
186${libdir}/${PYTHON_DIR}/site-packages/twisted/scripts/ \
187${libdir}/${PYTHON_DIR}/site-packages/twisted/spread/ \
188${libdir}/${PYTHON_DIR}/site-packages/twisted/tap/ \
189${libdir}/${PYTHON_DIR}/site-packages/twisted/trial/ \
190${libdir}/${PYTHON_DIR}/site-packages/twisted/__init__.py* \
191${libdir}/${PYTHON_DIR}/site-packages/twisted/_version.py* \
192${libdir}/${PYTHON_DIR}/site-packages/twisted/copyright.py* \
193${libdir}/${PYTHON_DIR}/site-packages/twisted/im.py* \
194${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py* \
195${libdir}/${PYTHON_DIR}/site-packages/twisted/python/*.py* \
196${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/*.py* \
197${libdir}/${PYTHON_DIR}/site-packages/twisted/topfiles \
198${libdir}/${PYTHON_DIR}/site-packages/Twisted*egg-info \
199${libdir}/${PYTHON_DIR}/site-packages/twisted/logger/ \
200${libdir}/${PYTHON_DIR}/site-packages/twisted/_threads/ \
201${libdir}/${PYTHON_DIR}/site-packages/twisted/positioning/ \
Andrew Geissler32b11992021-03-31 13:37:05 -0500202${libdir}/${PYTHON_DIR}/site-packages/twisted/py.typed \
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500203"
204
205FILES_${PN}-mail = " \
206${bindir}/mailmail \
207${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_mail.py* \
208${libdir}/${PYTHON_DIR}/site-packages/twisted/mail \
209"
210
211FILES_${PN}-names = " \
212${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_names.py* \
213${libdir}/${PYTHON_DIR}/site-packages/twisted/names \
214"
215
216FILES_${PN}-news = " \
217${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_news.py* \
218${libdir}/${PYTHON_DIR}/site-packages/twisted/news \
219"
220
221FILES_${PN}-runner = " \
222${libdir}/site-packages/twisted/runner/portmap.so \
223${libdir}/${PYTHON_DIR}/site-packages/twisted/runner\
224"
225
226FILES_${PN}-web = " \
227${bindir}/websetroot \
228${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_web.py* \
229${libdir}/${PYTHON_DIR}/site-packages/twisted/web\
230"
231
232FILES_${PN}-words = " \
233${bindir}/im \
234${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_words.py* \
235${libdir}/${PYTHON_DIR}/site-packages/twisted/words\
236"
237
238FILES_${PN}-flow = " \
239${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_flow.py* \
240${libdir}/${PYTHON_DIR}/site-packages/twisted/flow \"
241
242FILES_${PN}-pair = " \
243${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_pair.py* \
244${libdir}/${PYTHON_DIR}/site-packages/twisted/pair \
245"
246
247FILES_${PN}-dbg += " \
248${libdir}/${PYTHON_DIR}/site-packages/twisted/*/.debug \
249${libdir}/${PYTHON_DIR}/site-packages/twisted/*/*/.debug \
250"
251
252FILES_${PN}-doc += " \
253 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/_pydoctortemplates/ \
254"
255
Brad Bishop19323692019-04-05 15:28:33 -0400256RDEPENDS_${PN}-src = "${PN}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500257FILES_${PN}-src = " \
258 ${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py \
259 ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/*.py \
260 ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/*/*.py \
261"
Brad Bishop19323692019-04-05 15:28:33 -0400262
Andrew Geisslerc87764f2020-06-27 00:16:32 -0500263FILES_${PN}-core_append = " \
264 ${libdir}/${PYTHON_DIR}/site-packages/twisted/__pycache__ \
265 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/__pycache__/*pyc \
266 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/__init__*.pyc \
267 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/notestplugin*.pyc \
268 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/testplugin*.pyc \
269 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_ftp*.pyc \
270 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_inet*.pyc \
271 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_manhole*.pyc \
272 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_portforward*.pyc \
273 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_socks*.pyc \
274 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_telnet*.pyc \
275 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_trial*.pyc \
276 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_core*.pyc \
277 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_qtstub*.pyc \
278 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_reactors*.pyc \
279 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/cred*.pyc \
280 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/dropin*.cache \
281"
282
283FILES_${PN}-names_append = " \
284 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_names*.pyc \
285"
286
287FILES_${PN}-news_append = " \
288 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_news*.pyc \
289"
290
291FILES_${PN}-protocols_append = " \
292 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/__pycache__/*pyc \
293"
294
295FILES_${PN}-conch_append = " \
296 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_conch*.pyc \
297"
298
299FILES_${PN}-lore_append = " \
300 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_lore*.pyc \
301"
302FILES_${PN}-mail_append = " \
303 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_mail*.pyc \
304"
305
306FILES_${PN}-web_append = " \
307 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_web*.pyc \
308"
309
310FILES_${PN}-words_append = " \
311 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_words*.pyc \
312"
313
314FILES_${PN}-flow_append = " \
315 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_flow*.pyc \
316"
317
318FILES_${PN}-pair_append = " \
319 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_pair*.pyc \
320"
321
322FILES_${PN}-runner_append = " \
323 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_runner*.pyc \
324"