Andrew Geissler | 4b7c115 | 2020-11-30 19:55:29 -0600 | [diff] [blame] | 1 | SUMMARY = "Secure Reliable Transport (SRT) Protocol" |
| 2 | DESCRIPTION = "Secure Reliable Transport (SRT) is an open source transport technology \ |
| 3 | that optimizes streaming performance across unpredictable networks, such as the Internet." |
| 4 | SECTION = "libs" |
| 5 | HOMEPAGE = "https://github.com/Haivision/srt" |
| 6 | LICENSE = "MPL-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=815ca599c9df247a0c7f619bab123dad" |
| 8 | |
| 9 | SRCREV = "50b7af06f3a0a456c172b4cb3aceafa8a5cc0036" |
| 10 | SRC_URI = "git://github.com/Haivision/srt;protocol=https \ |
| 11 | file://0001-don-t-install-srt-ffplay.patch \ |
Andrew Geissler | 97771a3 | 2021-03-05 15:23:11 -0600 | [diff] [blame] | 12 | file://0001-core-Fix-build-with-GCC-11.-1806.patch \ |
Andrew Geissler | 4b7c115 | 2020-11-30 19:55:29 -0600 | [diff] [blame] | 13 | " |
| 14 | UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)" |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | inherit cmake pkgconfig |
| 18 | |
| 19 | EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release -DENABLE_UNITTESTS=OFF" |
| 20 | |
| 21 | PACKAGECONFIG ??= "crypt" |
| 22 | PACKAGECONFIG[debug] = "-DENABLE_DEBUG=1,," |
| 23 | PACKAGECONFIG[crypt] = "-DENABLE_ENCRYPTION=ON,-DENABLE_ENCRYPTION=OFF,openssl" |
| 24 | PACKAGECONFIG[utils] = "-DENABLE_APPS=ON,-DENABLE_APPS=OFF," |
| 25 | |
| 26 | PACKAGES += "${@bb.utils.contains('PACKAGECONFIG', 'utils', '${PN}-utils', '', d)}" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 27 | FILES:${PN}-utils += "${bindir}" |
| 28 | RDEPENDS:${PN}-utils += "${PN}" |