Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame^] | 1 | SUMMARY = "Lightweight and flexible command-line JSON processor" |
| 2 | DESCRIPTION = "jq is like sed for JSON data, you can use it to slice and \ |
| 3 | filter and map and transform structured data with the same \ |
| 4 | ease that sed, awk, grep and friends let you play with text." |
| 5 | HOMEPAGE = "https://stedolan.github.io/jq/" |
| 6 | BUGTRACKER = "https://github.com/stedolan/jq/issues" |
| 7 | SECTION = "utils" |
| 8 | LICENSE = "MIT" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=2814b59e00e7918c864fa3b6bbe049b4" |
| 10 | |
| 11 | PV = "1.6+git${SRCPV}" |
| 12 | SRC_URI = "git://github.com/stedolan/jq;protocol=https;branch=master" |
| 13 | SRCREV = "a9f97e9e61a910a374a5d768244e8ad63f407d3e" |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | inherit autotools-brokensep |
| 17 | |
| 18 | PACKAGECONFIG ?= "oniguruma" |
| 19 | |
| 20 | PACKAGECONFIG[docs] = "--enable-docs,--disable-docs,ruby-native" |
| 21 | PACKAGECONFIG[maintainer-mode] = "--enable-maintainer-mode,--disable-maintainer-mode,flex-native bison-native" |
| 22 | PACKAGECONFIG[oniguruma] = "--with-oniguruma,--without-oniguruma,onig" |
| 23 | |
| 24 | OE_EXTRACONF += " \ |
| 25 | --disable-valgrind \ |
| 26 | " |
| 27 | |
| 28 | BBCLASSEXTEND = "native" |