blob: 52648eb18b1d3c311abe758cc0390b4135c2914d [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Message Passing Interface (MPI) implementation"
2HOMEPAGE = "http://www.mpich.org/"
3SECTION = "devel"
4
5LICENSE = "BSD-2-Clause"
6LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=bd4d7ab13df98988b1ca2a4e01c8c163"
7
8SRC_URI = "http://www.mpich.org/static/downloads/${PV}/mpich-${PV}.tar.gz"
9SRC_URI[sha256sum] = "8154d89f3051903181018166678018155f4c2b6f04a9bb6fe9515656452c4fd7"
10
11RDEPENDS:${PN} += "bash perl libxml2"
12
13EXTRA_OECONF = "--enable-debuginfo \
14 --enable-fast \
15 --enable-shared \
16 --with-pm=gforker \
17 --disable-rpath \
18 --disable-f77 \
19 --disable-fc \
20 --disable-fortran \
21 --disable-cxx \
22 BASH_SHELL='${USRBINPATH}/env bash' \
23 PERL='${USRBINPATH}/env perl' \
24 --with-device=ch3:nemesis \
25 --with-rdmacm=no \
26 --disable-numa \
27"
28
29PACKAGECONFIG += " \
30 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)} \
31"
32PACKAGECONFIG[x11] = "--with-x --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR},--without-x,virtual/libx11"
33
34# libmpi.so needs symbols like __multf3 and somehow it does not respect --rtlib option passed by clang
35LDFLAGS:append:x86-64 = " -lgcc"
36LDFLAGS:append:x86 = " -lgcc"
37
38inherit autotools gettext pkgconfig
39
40do_configure() {
41 for d in confdb test/mpi test/mpi/confdb src/pm/hydra/confdb \
42 src/pm/hydra/tools/topo/hwloc/hwloc/config src/pm/hydra/mpl/confdb \
43 modules/yaksa/m4 modules/json-c modules/ucx test/mpi/dtpools/confdb \
44 src/mpl/confdb src/mpi/romio/confdb; do
45 install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}/$d
46 install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}/$d
47 done
48# cd ${S}
49# autoupdate
50# autoreconf --verbose --install --force
51# cd ${B}
52 oe_runconf
53}
54
55do_install:append() {
56 sed -i 's,${S}/,,g' ${D}/${libdir}/libmpi.la
57 sed -i 's,${DEBUG_PREFIX_MAP},,g' ${D}/${libdir}/pkgconfig/mpich.pc
58}