Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | DESCRIPTION = "This is a userland SCTP stack supporting FreeBSD, Linux, Mac OS X and Windows." |
| 2 | LICENSE = "BSD-3-Clause" |
| 3 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=ffcf846341f3856d79a483eafa18e2a5" |
| 4 | |
Brad Bishop | 868407c | 2019-11-04 13:24:47 -0500 | [diff] [blame] | 5 | SRCREV = "a10cd498d964508c0e6ec6bd2be9dd4afcbb4d86" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 6 | SRC_URI = "git://github.com/sctplab/usrsctp;protocol=https;branch=master \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 7 | " |
| 8 | |
| 9 | S = "${WORKDIR}/git" |
| 10 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 11 | UPSTREAM_CHECK_COMMITS = "1" |
| 12 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 13 | inherit autotools pkgconfig |
| 14 | |
| 15 | DEPENDS += "openssl" |
| 16 | |
| 17 | CFLAGS += "-DSCTP_USE_OPENSSL_SHA1 -fPIC" |
| 18 | LDFLAGS += "-lssl -lcrypto" |
| 19 | |
| 20 | PACKAGECONFIG ?= "disablewarnings inet inet6" |
| 21 | PACKAGECONFIG[disablewarnings] = "--disable-warnings-as-errors,," |
| 22 | PACKAGECONFIG[inet] = "--enable-inet,--disable-inet," |
| 23 | PACKAGECONFIG[inet6] = "--enable-inet6,--disable-inet6," |
| 24 | |
| 25 | EXTRA_OECONF += "--disable-debug" |