Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Universal encoding detector for Python 2 and 3" |
| 2 | LICENSE = "LGPL-2.1" |
| 3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a6f89e2100d9b6cdffcea4f398e37343" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 4 | |
Andrew Geissler | 72956ed | 2021-01-08 16:11:14 -0600 | [diff] [blame] | 5 | SRC_URI[sha256sum] = "0d6f53a15db4120f2b08c94f11e7d93d2c911ee118b6b30a04ec3ee8310179fa" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 6 | |
| 7 | # setup.py of chardet needs this. |
| 8 | DEPENDS += "${PYTHON_PN}-pytest-runner-native" |
| 9 | |
| 10 | inherit pypi setuptools3 |
| 11 | |
| 12 | PACKAGES =+ "${PN}-cli" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 13 | FILES:${PN}-cli += " \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 14 | ${PYTHON_SITEPACKAGES_DIR}/chardet/cli \ |
| 15 | " |
| 16 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 17 | RDEPENDS:${PN}-cli = "${PN} " |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 18 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 19 | RDEPENDS:${PN}:class-target += " \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 20 | ${PYTHON_PN}-logging \ |
| 21 | " |
| 22 | |
| 23 | BBCLASSEXTEND = "native nativesdk" |