Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | DESCRIPTION = "Collection of Vulkan examples" |
| 2 | LICENSE = "MIT" |
| 3 | DEPENDS = "zlib" |
| 4 | |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=dcf473723faabf17baa9b5f2207599d0 \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 6 | file://examples/triangle/triangle.cpp;endline=12;md5=bccd1bf9cadd9e10086cf7872157e4fa" |
| 7 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 8 | SRCREV_glm = "1ad55c5016339b83b7eec98c31007e0aee57d2bf" |
Andrew Geissler | c182c62 | 2020-05-15 14:13:32 -0500 | [diff] [blame] | 9 | SRCREV_ktx = "726d14d02c95bb21ec9e43807751b491d295dd3c" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 10 | |
| 11 | SRC_URI = "git://github.com/SaschaWillems/Vulkan.git \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 12 | git://github.com/g-truc/glm;destsuffix=git/external/glm;name=glm \ |
Andrew Geissler | c182c62 | 2020-05-15 14:13:32 -0500 | [diff] [blame] | 13 | git://github.com/KhronosGroup/KTX-Software;destsuffix=git/external/ktx;name=ktx;lfs=0 \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 14 | file://0001-Don-t-build-demos-with-questionably-licensed-data.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 15 | " |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 16 | UPSTREAM_CHECK_COMMITS = "1" |
Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame^] | 17 | SRCREV = "4818f85916bf88c1ca8c2ed1a46e0e758651489e" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 18 | UPSTREAM_CHECK_GITTAGREGEX = "These are not the releases you're looking for" |
| 19 | S = "${WORKDIR}/git" |
| 20 | |
| 21 | REQUIRED_DISTRO_FEATURES = 'vulkan' |
| 22 | |
Brad Bishop | 6dbb316 | 2019-11-25 09:41:34 -0500 | [diff] [blame] | 23 | inherit cmake features_check |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 24 | DEPENDS = "vulkan-loader assimp wayland-protocols wayland-native" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 25 | |
| 26 | do_install_append () { |
| 27 | # Remove assets that have uncertain licenses |
| 28 | rm ${D}${datadir}/vulkan-demos/models/armor/* \ |
| 29 | ${D}${datadir}/vulkan-demos/models/sibenik/* \ |
| 30 | ${D}${datadir}/vulkan-demos/models/vulkanscene* \ |
| 31 | ${D}${datadir}/vulkan-demos/models/plants.dae \ |
| 32 | ${D}${datadir}/vulkan-demos/textures/texturearray_plants* |
| 33 | |
| 34 | mv ${D}${bindir}/screenshot ${D}${bindir}/vulkan-screenshot |
| 35 | } |
| 36 | |
| 37 | EXTRA_OECMAKE = "-DRESOURCE_INSTALL_DIR=${datadir}/vulkan-demos" |
| 38 | |
| 39 | ANY_OF_DISTRO_FEATURES = "x11 wayland" |
| 40 | |
| 41 | # Can only pick one of [wayland,xcb] |
| 42 | PACKAGECONFIG = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', 'xcb' ,d)}" |
| 43 | PACKAGECONFIG[wayland] = "-DUSE_WAYLAND_WSI=ON, -DUSE_WAYLAND_WSI=OFF, wayland" |
| 44 | PACKAGECONFIG[xcb] = ",,libxcb" |