Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "Set of i2c tools for linux" |
| 2 | HOMEPAGE = "https://i2c.wiki.kernel.org/index.php/I2C_Tools" |
| 3 | SECTION = "base" |
| 4 | LICENSE = "GPLv2+" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" |
| 6 | |
| 7 | SRC_URI = "${KERNELORG_MIRROR}/software/utils/i2c-tools/${BP}.tar.gz \ |
| 8 | file://0001-lib-Module.mk-Add-missing-dependencies.patch \ |
| 9 | file://0001-tools-Module.mk-Add-missing-dependencies.patch \ |
| 10 | file://0001-i2c-tools-eeprog-Module.mk-Add-missing-dependency.patch \ |
| 11 | file://remove-i2c-dev.patch \ |
| 12 | " |
| 13 | |
| 14 | SRC_URI[md5sum] = "d92a288d70f306d3895e3a7e9c14c9aa" |
| 15 | SRC_URI[sha256sum] = "5b60daf6f011de0acb61de57dba62f2054bb39f19961d67e0c91610f071ca403" |
| 16 | |
| 17 | EXTRA_OEMAKE = "bindir=${bindir} sbindir=${sbindir} \ |
| 18 | incdir=${includedir} libdir=${libdir} \ |
| 19 | mandir=${mandir} \ |
| 20 | EXTRA=eeprog" |
| 21 | |
| 22 | do_install() { |
| 23 | oe_runmake 'DESTDIR=${D}' install |
| 24 | } |
| 25 | |
| 26 | PACKAGES =+ "${PN}-misc" |
| 27 | FILES_${PN}-misc = "${sbindir}/i2c-stub-from-dump \ |
| 28 | ${bindir}/ddcmon \ |
| 29 | ${bindir}/decode-edid \ |
| 30 | ${bindir}/decode-dimms \ |
| 31 | ${bindir}/decode-vaio \ |
| 32 | " |
| 33 | RDEPENDS_${PN}-misc = "${PN} perl perl-module-posix \ |
| 34 | perl-module-constant perl-module-file-basename \ |
| 35 | perl-module-fcntl perl-module-strict perl-module-vars \ |
| 36 | " |