Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 1 | SUMMARY = "XCB: The X protocol C binding library" |
| 2 | DESCRIPTION = "The X protocol C-language Binding (XCB) is a replacement \ |
| 3 | for Xlib featuring a small footprint, latency hiding, direct access to \ |
| 4 | the protocol, improved threading support, and extensibility." |
| 5 | HOMEPAGE = "http://xcb.freedesktop.org" |
| 6 | BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=XCB" |
| 7 | SECTION = "x11/libs" |
| 8 | |
| 9 | LICENSE = "MIT" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=d763b081cb10c223435b01e00dc0aba7" |
| 11 | |
| 12 | SRC_URI = "http://xcb.freedesktop.org/dist/libxcb-${PV}.tar.bz2 \ |
| 13 | file://xcbincludedir.patch \ |
| 14 | file://disable-check.patch \ |
| 15 | file://gcc-mips-pr68302-mips-workaround.patch \ |
| 16 | file://Fix-inconsistent-use-of-tabs-vs.-space.patch \ |
| 17 | " |
| 18 | SRC_URI[md5sum] = "28e552bd78bc1050b6b26ca1db0e5bb6" |
| 19 | SRC_URI[sha256sum] = "4adfb1b7c67e99bc9c2ccb110b2f175686576d2f792c8a71b9c8b19014057b5b" |
| 20 | |
| 21 | BBCLASSEXTEND = "native nativesdk" |
| 22 | |
| 23 | DEPENDS = "xcb-proto xproto libxau libpthread-stubs libxdmcp" |
| 24 | |
| 25 | PACKAGES_DYNAMIC = "^libxcb-.*" |
| 26 | |
| 27 | FILES_${PN} = "${libdir}/libxcb.so.*" |
| 28 | |
| 29 | inherit autotools pkgconfig distro_features_check |
| 30 | |
| 31 | # The libxau and others requires x11 in DISTRO_FEATURES |
| 32 | REQUIRED_DISTRO_FEATURES = "x11" |
| 33 | REQUIRED_DISTRO_FEATURES_class-native = "" |
| 34 | |
| 35 | export PYTHON = "python3" |
| 36 | |
| 37 | python populate_packages_prepend () { |
| 38 | do_split_packages(d, '${libdir}', '^libxcb-(.*)\.so\..*$', 'libxcb-%s', 'XCB library module for %s', allow_links=True) |
| 39 | } |