Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "MessagePack (de)serializer" |
| 2 | LICENSE = "Apache-2.0" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=cd9523181d9d4fbf7ffca52eaa2a5751" |
| 4 | |
| 5 | PYPI_PACKAGE = "msgpack" |
| 6 | inherit pypi setuptools3 ptest |
| 7 | |
| 8 | SRC_URI[sha256sum] = "51fdc7fb93615286428ee7758cecc2f374d5ff363bdd884c7ea622a7a327a81e" |
| 9 | |
| 10 | RDEPENDS:${PN}:class-target += "\ |
| 11 | ${PYTHON_PN}-io \ |
| 12 | " |
| 13 | |
| 14 | BBCLASSEXTEND = "native nativesdk" |
| 15 | |
| 16 | SRC_URI += " \ |
| 17 | file://run-ptest \ |
| 18 | " |
| 19 | |
| 20 | RDEPENDS:${PN}-ptest += " \ |
| 21 | ${PYTHON_PN}-pytest \ |
| 22 | " |
| 23 | |
| 24 | do_install_ptest() { |
| 25 | install -d ${D}${PTEST_PATH}/test |
| 26 | cp -rf ${S}/test/* ${D}${PTEST_PATH}/test/ |
| 27 | } |