Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "OBEX Server and Client" |
| 2 | # obexd was integrated into bluez5 |
| 3 | DEPENDS = "glib-2.0 dbus libical" |
| 4 | DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES','bluez5','bluez5','bluez4',d)}" |
| 5 | |
| 6 | LICENSE = "GPLv2" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e" |
| 8 | |
| 9 | SRC_URI = "http://www.kernel.org/pub/linux/bluetooth/obexd-${PV}.tar.gz \ |
| 10 | file://ssize_t_definition.patch \ |
| 11 | " |
| 12 | SRC_URI[md5sum] = "d03cf9bad2983243837f4f6d76ef14a6" |
| 13 | SRC_URI[sha256sum] = "eaa9d8d9542700e6750918d72a3ce00f8cf3a2771d3e2516efd1be5a05f78582" |
| 14 | |
| 15 | inherit autotools-brokensep pkgconfig |
| 16 | |
| 17 | PACKAGES =+ "obex-client obex-plugins" |
| 18 | |
| 19 | FILES_${PN} += "${datadir}/dbus-1/services/${PN}.service" |
| 20 | FILES_obex-client = "${libexecdir}/obex-client \ |
| 21 | ${datadir}/dbus-1/services/obex-client.service" |
| 22 | # currently the plugins are empty |
| 23 | FILES_obex-plugins = "${libdir}/obex/plugins" |