Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | DESCRIPTION = "TinyALSA is a small library to interface with ALSA in \ |
| 2 | the Linux kernel. It is a lightweight alternative to libasound." |
| 3 | HOMEPAGE = "https://github.com/tinyalsa/tinyalsa" |
| 4 | SECTION = "libs/multimedia" |
| 5 | |
| 6 | LICENSE = "BSD-3-Clause" |
| 7 | LIC_FILES_CHKSUM = "file://NOTICE;md5=dbdefe400d894b510a9de14813181d0b" |
| 8 | |
| 9 | S = "${WORKDIR}/git" |
| 10 | SRCREV = "df11091086b56e5fb71887f2fa320e1d2ffeff58" |
| 11 | SRC_URI = "git://github.com/tinyalsa/tinyalsa.git;protocol=https;" |
| 12 | |
| 13 | do_configure() { |
| 14 | : |
| 15 | } |
| 16 | |
| 17 | do_compile() { |
| 18 | oe_runmake CC='${CC}' LD='${CC}' AR='${AR}' |
| 19 | } |
| 20 | |
| 21 | do_install() { |
| 22 | oe_runmake install \ |
| 23 | PREFIX="${prefix}" DESTDIR="${D}" INCDIR="${includedir}/tinyalsa" \ |
| 24 | LIBDIR="${libdir}" BINDIR="${bindir}" MANDIR="${mandir}" |
| 25 | } |
| 26 | |
| 27 | PACKAGES =+ "${PN}-tools" |
| 28 | FILES_${PN}-tools = "${bindir}/*" |