Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | SUMMARY = "Manage plain dm-crypt and LUKS encrypted volumes" |
| 2 | DESCRIPTION = "Cryptsetup is used to conveniently setup dm-crypt managed \ |
| 3 | device-mapper mappings. These include plain dm-crypt volumes and \ |
| 4 | LUKS volumes. The difference is that LUKS uses a metadata header \ |
| 5 | and can hence offer more features than plain dm-crypt. On the other \ |
| 6 | hand, the header is visible and vulnerable to damage." |
| 7 | HOMEPAGE = "http://code.google.com/p/cryptsetup/" |
| 8 | SECTION = "console" |
| 9 | LICENSE = "GPL-2.0-with-OpenSSL-exception" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=32107dd283b1dfeb66c9b3e6be312326" |
| 11 | |
| 12 | DEPENDS = "util-linux libdevmapper popt libgcrypt" |
| 13 | |
| 14 | SRC_URI = "${KERNELORG_MIRROR}/linux/utils/${BPN}/v1.7/${BP}.tar.xz" |
| 15 | SRC_URI[md5sum] = "058ed35c5b776032c2a036838f9e22a7" |
| 16 | SRC_URI[sha256sum] = "7ccf893ef79a38fb92d61f03c17b964982119f5319cdaa85a1335b8558cca016" |
| 17 | |
| 18 | inherit autotools gettext pkgconfig |
| 19 | |
| 20 | # Use openssl because libgcrypt drops root privileges |
| 21 | # if libgcrypt is linked with libcap support |
| 22 | PACKAGECONFIG ??= "openssl" |
| 23 | PACKAGECONFIG[openssl] = "--with-crypto_backend=openssl,,openssl" |
| 24 | PACKAGECONFIG[gcrypt] = "--with-crypto_backend=gcrypt,,libgcrypt" |
| 25 | |
| 26 | RRECOMMENDS_${PN} = "kernel-module-aes-generic \ |
| 27 | kernel-module-dm-crypt \ |
| 28 | kernel-module-md5 \ |
| 29 | kernel-module-cbc \ |
| 30 | kernel-module-sha256-generic \ |
| 31 | kernel-module-xts \ |
| 32 | " |
| 33 | |
| 34 | EXTRA_OECONF = "--enable-static" |
| 35 | |
| 36 | BBCLASSEXTEND = "native nativesdk" |