Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Trace and analyze execution of a program written in C/C++" |
| 2 | HOMEPAGE = "https://github.com/namhyung/uftrace" |
| 3 | BUGTRACKER = "https://github.com/namhyung/uftrace/issues" |
| 4 | SECTION = "devel" |
| 5 | LICENSE = "GPLv2" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 7 | |
| 8 | DEPENDS = "elfutils" |
| 9 | DEPENDS_append_libc-musl = " argp-standalone" |
| 10 | |
| 11 | inherit autotools |
| 12 | |
| 13 | SRCREV = "5af9ff9fa89c340617e52c8ed05798b352a7145c" |
| 14 | SRC_URI = "git://github.com/namhyung/${BPN}" |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | LDFLAGS_append_libc-musl = " -largp" |
| 18 | EXTRA_OECONF = "ARCH=${TARGET_ARCH}" |
| 19 | |
| 20 | do_configure() { |
| 21 | ${S}/configure ${EXTRA_OECONF} |
| 22 | } |
| 23 | |
| 24 | FILES_SOLIBSDEV = "" |
| 25 | FILES_${PN} += "${libdir}/*.so" |
| 26 | |
| 27 | COMPATIBLE_HOST = "(x86_64|aarch64|arm)" |
| 28 | |
| 29 | # uftrace supports armv6 and above |
| 30 | COMPATIBLE_HOST_armv4 = 'null' |
| 31 | COMPATIBLE_HOST_armv5 = 'null' |