Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "haveged - A simple entropy daemon" |
| 2 | DESCRIPTION = "The haveged project is an attempt to provide an easy-to-use, unpredictable random number generator based upon an adaptation of the HAVEGE algorithm. Haveged was created to remedy low-entropy conditions in the Linux random device that can occur under some workloads, especially on headless servers." |
| 3 | AUTHOR = "Gary Wuertz" |
| 4 | HOMEPAGE = "http://www.issihosts.com/haveged/index.html" |
| 5 | LICENSE = "GPLv3" |
| 6 | LIC_FILES_CHKSUM="file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 7 | |
| 8 | SRC_URI = "http://www.issihosts.com/haveged/haveged-${PV}.tar.gz \ |
| 9 | file://haveged-init.d-Makefile.am-add-missing-dependency.patch \ |
| 10 | " |
| 11 | |
| 12 | SRC_URI[md5sum] = "fb1d8b3dcbb9d06b30eccd8aa500fd31" |
| 13 | SRC_URI[sha256sum] = "f77d9adbdf421b61601fa29faa9ce3b479d910f73c66b9e364ba8642ccbfbe70" |
| 14 | |
| 15 | inherit autotools update-rc.d systemd |
| 16 | |
| 17 | EXTRA_OECONF = "\ |
| 18 | --enable-nistest=yes \ |
| 19 | --enable-olt=yes \ |
| 20 | --enable-threads=no \ |
| 21 | " |
| 22 | |
| 23 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" |
| 24 | PACKAGECONFIG[systemd] = "--enable-init=service.redhat --enable-initdir=${systemd_system_unitdir}, --enable-init=sysv.redhat, systemd" |
| 25 | |
| 26 | INITSCRIPT_PACKAGES = "${PN}" |
| 27 | INITSCRIPT_NAME = "haveged" |
| 28 | INITSCRIPT_PARAMS_${PN} = "defaults 9" |
| 29 | |
| 30 | SYSTEMD_PACKAGES = "${PN}" |
| 31 | SYSTEMD_SERVICE_${PN} = "haveged.service" |
| 32 | |
| 33 | do_install_append() { |
| 34 | # The exit status is 143 when the service is stopped |
| 35 | if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then |
| 36 | sed -i '/ExecStart/a SuccessExitStatus=143' ${D}${systemd_system_unitdir}/haveged.service |
| 37 | fi |
| 38 | } |
| 39 | |
| 40 | MIPS_INSTRUCTION_SET = "mips" |