Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "Character Based User Interface for libyui" |
| 2 | LICENSE = "LGPLv3" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING.lgpl-3;md5=e6a600fd5e1d9cbde2d983680233ad02 \ |
| 4 | file://COPYING.lgpl-2.1;md5=4fbd65380cdd255951079008b364516c \ |
| 5 | " |
| 6 | |
| 7 | SRC_URI = "git://github.com/libyui/libyui-ncurses.git \ |
| 8 | file://0001-use-_nl_msg_cat_cntr-only-with-glibc.patch \ |
| 9 | " |
| 10 | |
| 11 | SRC_URI_append_class-target = " file://0001-Fix-the-error-of-can-t-find-header-file.patch" |
| 12 | |
| 13 | PV = "2.48.3+git${SRCPV}" |
| 14 | SRCREV = "79b804b45ffc6a0d92e28e793ff389a20b63b54b" |
| 15 | |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | inherit cmake gettext pkgconfig |
| 19 | |
| 20 | DEPENDS += "boost libyui ncurses" |
| 21 | |
| 22 | BBCLASSEXTEND = "nativesdk" |
| 23 | |
| 24 | do_configure_prepend () { |
| 25 | cd ${S} |
| 26 | git checkout bootstrap.sh |
| 27 | sed -i "s#/usr#${PKG_CONFIG_SYSROOT_DIR}${base_prefix}&#" bootstrap.sh |
| 28 | ./bootstrap.sh |
| 29 | mkdir -p ${PKG_CONFIG_SYSROOT_DIR}${base_prefix}/usr/lib64/ |
| 30 | cp ${PKG_CONFIG_SYSROOT_DIR}${base_prefix}/usr/lib/libyui.so* ${PKG_CONFIG_SYSROOT_DIR}${base_prefix}/usr/lib64/ |
| 31 | cd - |
| 32 | sed -i "s#\${YPREFIX}#\${PKG_CONFIG_SYSROOT_DIR}${base_prefix}&#" ${S}/CMakeLists.txt |
| 33 | sed -i "s#/usr#${PKG_CONFIG_SYSROOT_DIR}${base_prefix}&#" ${PKG_CONFIG_SYSROOT_DIR}${libdir}/cmake/libyui/LibyuiLibraryDepends-release.cmake |
| 34 | } |
| 35 | |
| 36 | do_install_append () { |
| 37 | if [ "${libdir}" = "${base_prefix}/usr/lib" ] && [ -d ${D}/usr/lib64 ]; then |
| 38 | mv ${D}/usr/lib64 ${D}/usr/lib |
| 39 | fi |
| 40 | } |
| 41 | |
| 42 | do_install_append_class-nativesdk () { |
| 43 | mkdir -p ${D}/${base_prefix} |
| 44 | mv ${D}/usr ${D}/${base_prefix} |
| 45 | } |
| 46 | |
| 47 | FILES_${PN} += "${datadir}/*" |
| 48 | |
| 49 | FILES_${PN}-dev += "${libdir}/*" |