Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "Libyui is a widget abstraction library providing Qt, GTK and ncurses frontends." |
| 2 | LICENSE = "LGPLv3" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING.gpl-3;md5=d32239bcb673463ab874e80d47fae504 \ |
| 4 | file://COPYING.lgpl-2.1;md5=4fbd65380cdd255951079008b364516c \ |
| 5 | file://COPYING.lgpl-3;md5=e6a600fd5e1d9cbde2d983680233ad02 \ |
| 6 | " |
| 7 | |
| 8 | SRC_URI = "git://github.com/libyui/libyui.git \ |
| 9 | file://0001-Fix-GCC-8-warning.patch \ |
| 10 | file://0001-Fix-build-with-clang.patch \ |
| 11 | " |
| 12 | |
| 13 | PV = "3.3.3+git" |
| 14 | SRCREV = "2b634cb7821e2e79dd4b7a73caf8e67c50189376" |
| 15 | |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | inherit cmake gettext pkgconfig |
| 19 | |
| 20 | DEPENDS += "boost" |
| 21 | |
| 22 | BBCLASSEXTEND = "native nativesdk" |
| 23 | |
| 24 | do_configure_prepend () { |
| 25 | cd ${S} |
| 26 | ./bootstrap.sh |
| 27 | cd - |
| 28 | } |
| 29 | |
| 30 | do_install_append () { |
| 31 | if [ "${libdir}" = "${base_prefix}/usr/lib" ] && [ -d ${D}/usr/lib64 ]; then |
| 32 | mv ${D}/usr/lib64 ${D}/usr/lib |
| 33 | fi |
| 34 | } |
| 35 | |
| 36 | do_install_append_class-nativesdk () { |
| 37 | mkdir -p ${D}/${base_prefix} |
| 38 | mv ${D}/usr ${D}/${base_prefix} |
| 39 | } |
| 40 | |
| 41 | FILES_${PN}-dev = "${libdir}/* ${includedir}/yui*" |