Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "VMcore extraction tool" |
| 2 | DESCRIPTION = "\ |
| 3 | This program is used to extract a subset of the memory available either \ |
| 4 | via /dev/mem or /proc/vmcore (for crashdumps). It is used to get memory \ |
| 5 | images without extra uneeded information (zero pages, userspace programs, \ |
| 6 | etc). \ |
| 7 | " |
| 8 | HOMEPAGE = "http://makedumpfile.sourceforge.net" |
| 9 | |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" |
| 11 | LICENSE = "GPLv2.0" |
| 12 | |
| 13 | DEPENDS = "bzip2 zlib elfutils" |
| 14 | RDEPENDS_${PN}-tools = "perl ${PN}" |
| 15 | |
| 16 | # arm would compile but has never been tested upstream. mips would not compile. |
| 17 | # |
| 18 | COMPATIBLE_HOST = "(x86_64|i.86|powerpc|arm).*-linux" |
| 19 | |
| 20 | PACKAGES =+ "${PN}-tools" |
| 21 | FILES_${PN}-tools = "${bindir}/*.pl" |
| 22 | |
| 23 | SRC_URI = "\ |
| 24 | ${SOURCEFORGE_MIRROR}/makedumpfile/${BPN}-${PV}.tar.gz \ |
| 25 | file://0001-makedumpfile-replace-hardcode-CFLAGS.patch \ |
| 26 | file://0002-mem_section-Support-only-46-bit-for-MAX_PHYSMEM_BITS.patch \ |
| 27 | " |
| 28 | SRC_URI[md5sum] = "72be5bf973eed898c5127e3abc466583" |
| 29 | SRC_URI[sha256sum] = "ee3d21cb4032a60bd2c802d1d8b21b9f399710e1574f8de8ead5ab50cd821a6d" |
| 30 | |
| 31 | SECTION = "base" |
| 32 | |
| 33 | # If we do not specify TARGET, makedumpfile will build for the host but use the |
| 34 | # target gcc. |
| 35 | # |
| 36 | EXTRA_OEMAKE = "\ |
| 37 | LINKTYPE=static \ |
| 38 | TARGET=${TARGET_ARCH} \ |
| 39 | " |
| 40 | |
| 41 | do_install () { |
| 42 | mkdir -p ${D}/usr/bin |
| 43 | install -m 755 ${S}/makedumpfile ${D}/usr/bin |
| 44 | install -m 755 ${S}/makedumpfile-R.pl ${D}/usr/bin |
| 45 | |
| 46 | mkdir -p ${D}/usr/share/man/man8 |
| 47 | install -m 644 ${S}/makedumpfile.8.gz ${D}/usr/share/man/man8 |
| 48 | |
| 49 | mkdir -p ${D}/usr/share/man/man5 |
| 50 | install -m 644 ${S}/makedumpfile.conf.5.gz ${D}/usr/share/man/man5 |
| 51 | |
| 52 | mkdir -p ${D}/etc/ |
| 53 | install -m 644 ${S}/makedumpfile.conf ${D}/etc/makedumpfile.conf.sample |
| 54 | } |