Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "Net::SSLeay - Perl extension for using OpenSSL" |
| 2 | DESCRIPTION = "This module offers some high level convenience functions for accessing \ |
| 3 | web pages on SSL servers (for symmetry, same API is offered for \ |
| 4 | accessing http servers, too), a sslcat() function for writing your own \ |
| 5 | clients, and finally access to the SSL api of SSLeay/OpenSSL package \ |
| 6 | so you can write servers or clients for more complicated applications." |
| 7 | HOMEPAGE = "http://search.cpan.org/dist/Net-SSLeay/" |
| 8 | SECTION = "libs" |
| 9 | |
| 10 | LICENSE = "Artistic-1.0 | GPL-1.0+" |
| 11 | LIC_FILES_CHKSUM = "file://README;beginline=274;endline=294;md5=67d67095d83e339da538a082fad5f38e" |
| 12 | |
| 13 | DEPENDS = "openssl zlib openssl-native" |
| 14 | RDEPENDS_${PN} += "\ |
| 15 | libssl \ |
| 16 | libcrypto \ |
| 17 | perl-module-carp \ |
| 18 | perl-module-errno \ |
| 19 | perl-module-extutils-makemaker \ |
| 20 | perl-module-mime-base64 \ |
| 21 | perl-module-socket \ |
| 22 | zlib \ |
| 23 | " |
| 24 | |
| 25 | SRC_URI = "http://search.cpan.org/CPAN/authors/id/M/MI/MIKEM/Net-SSLeay-${PV}.tar.gz \ |
| 26 | file://run-ptest \ |
| 27 | " |
| 28 | SRC_URI[md5sum] = "cfbe968487149626978f427cc9fb8c77" |
| 29 | SRC_URI[sha256sum] = "823ec3cbb428309d6a9e56f362a9300693ce3215b7fede109adb7be361fff177" |
| 30 | |
| 31 | S = "${WORKDIR}/Net-SSLeay-${PV}" |
| 32 | |
| 33 | inherit cpan ptest |
| 34 | |
| 35 | export OPENSSL_PREFIX="${STAGING_LIBDIR}" |
| 36 | |
| 37 | EXTRA_CPANFLAGS = "INC=-I${STAGING_INCDIR} LIBS='-L${STAGING_LIBDIR} -lcrypto -lssl -L${STAGING_BASELIBDIR} -lz'" |
| 38 | |
| 39 | do_install_ptest() { |
| 40 | cp -r ${B}/t ${D}${PTEST_PATH} |
| 41 | } |
| 42 | |
| 43 | BBCLASSEXTEND = "native" |
| 44 | |
| 45 | FILES_${PN}-dbg =+ "${libdir}/perl/vendor_perl/*/auto/Net/SSLeay/.debug/" |
| 46 | |
| 47 | RDEPENDS_${PN}-ptest = " perl" |