Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | DESCRIPTION = "A python module for system storage configuration" |
| 2 | HOMEPAGE = "http://fedoraproject.org/wiki/blivet" |
| 3 | LICENSE = "LGPLv2+" |
| 4 | SECTION = "devel/python" |
| 5 | |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 7 | |
| 8 | S = "${WORKDIR}/git" |
| 9 | B = "${S}" |
| 10 | |
| 11 | SRCREV = "39db82f20d8d4904c0c4dc8912e595177c59e091" |
| 12 | SRC_URI = "git://github.com/rhinstaller/blivet;branch=2.2-devel \ |
| 13 | file://0001-comment-out-selinux.patch \ |
| 14 | file://0002-run_program-support-timeout.patch\ |
| 15 | file://0003-support-infinit-timeout.patch \ |
| 16 | file://0004-Mount-var-volatile-during-install.patch \ |
| 17 | file://0005-update-fstab-by-appending.patch \ |
| 18 | file://0006-fix-new.roots-object-is-not-iterable.patch \ |
| 19 | file://0007-fix-incorrect-timeout-while-system-time-changed.patch \ |
| 20 | file://0008-tweak-btrfs-packages.patch \ |
| 21 | file://0009-invoking-mount-with-infinite-timeout.patch \ |
| 22 | file://0010-use-oe-variable-to-replace-hardcoded-dir.patch \ |
| 23 | file://0011-invoking-fsck-with-infinite-timeout.patch \ |
| 24 | file://0012-invoking-mkfs-with-infinite-timeout.patch \ |
| 25 | file://0013-Revert-Adapt-to-logging-module-name-change.patch \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 26 | file://0014-invoking-dd-with-infinite-timeout.patch \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 27 | " |
| 28 | |
| 29 | inherit distro_features_check |
| 30 | REQUIRED_DISTRO_FEATURES = "systemd" |
| 31 | |
| 32 | inherit setuptools3 python3native |
| 33 | |
| 34 | RDEPENDS_${PN} = "python3-pykickstart python3-pyudev \ |
| 35 | parted python3-pyparted multipath-tools \ |
| 36 | lsof cryptsetup libblockdev \ |
| 37 | libbytesize \ |
| 38 | " |
| 39 | |
| 40 | FILES_${PN} += " \ |
| 41 | ${datadir}/dbus-1/system-services \ |
| 42 | " |
| 43 | |
| 44 | inherit systemd |
| 45 | |
| 46 | SYSTEMD_AUTO_ENABLE = "disable" |
| 47 | SYSTEMD_SERVICE_${PN} = "blivet.service" |