Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | DESCRIPTION = "GUI tool for storage configuration using blivet library" |
| 2 | HOMEPAGE = "https://github.com/rhinstaller/blivet-gui" |
| 3 | LICENSE = "GPLv2+" |
| 4 | SECTION = "devel/python" |
| 5 | |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 7 | |
| 8 | S = "${WORKDIR}/git" |
| 9 | B = "${S}" |
| 10 | |
| 11 | SRCREV = "52ae8c000843c05abd1d8749f44bbe2e5d891d3d" |
| 12 | SRC_URI = "git://github.com/rhinstaller/blivet-gui;branch=master \ |
| 13 | " |
| 14 | |
| 15 | inherit distro_features_check |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 16 | REQUIRED_DISTRO_FEATURES = "x11 systemd" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 17 | |
| 18 | inherit setuptools3 python3native |
| 19 | |
| 20 | RDEPENDS_${PN} = "python3-pygobject python3 \ |
| 21 | python3-blivet gtk+3 \ |
| 22 | python3-pid libreport \ |
| 23 | " |
| 24 | |
| 25 | FILES_${PN} += " \ |
| 26 | ${datadir}/* \ |
| 27 | " |