Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 1 | # Copyright (C) 2017 Armin Kuster <akuster808@gmail.com> |
| 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
| 3 | |
| 4 | SUMMARY = "Lynis is a free and open source security and auditing tool." |
| 5 | HOMEDIR = "https://cisofy.com/" |
| 6 | LICENSE = "GPL-3.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3edd6782854304fd11da4975ab9799c1" |
| 8 | |
Stefan Lendl | 956c048 | 2018-11-15 16:02:18 +0100 | [diff] [blame] | 9 | SRCREV= "1be5154b35ce144db4f386856debe8a06b403899" |
| 10 | SRC_URI = "git://github.com/CISOfy/Lynis.git" |
| 11 | S = "${WORKDIR}/git" |
Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 12 | |
| 13 | inherit autotools-brokensep |
| 14 | |
| 15 | do_compile[noexec] = "1" |
| 16 | do_configure[noexec] = "1" |
| 17 | |
| 18 | do_install () { |
| 19 | install -d ${D}/${bindir} |
| 20 | install -d ${D}/${sysconfdir}/lynis |
| 21 | install -m 555 ${S}/lynis ${D}/${bindir} |
| 22 | |
| 23 | install -d ${D}/${datadir}/lynis/db |
| 24 | install -d ${D}/${datadir}/lynis/plugins |
| 25 | install -d ${D}/${datadir}/lynis/include |
| 26 | install -d ${D}/${datadir}/lynis/extras |
| 27 | |
| 28 | cp -r ${S}/db/* ${D}/${datadir}/lynis/db/. |
| 29 | cp -r ${S}/plugins/* ${D}/${datadir}/lynis/plugins/. |
| 30 | cp -r ${S}/include/* ${D}/${datadir}/lynis/include/. |
| 31 | cp -r ${S}/extras/* ${D}/${datadir}/lynis/extras/. |
| 32 | cp ${S}/*.prf ${D}/${sysconfdir}/lynis |
| 33 | } |
| 34 | |
| 35 | FILES_${PN} += "${sysconfdir}/developer.prf ${sysconfdir}/default.prf" |
| 36 | FILES_${PN}-doc += "lynis.8 FAQ README CHANGELOG.md CONTRIBUTIONS.md CONTRIBUTORS.md" |
| 37 | |
| 38 | RDEPENDS_${PN} += "procps" |