Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "Power usage tool" |
| 2 | DESCRIPTION = "Linux tool to diagnose issues with power consumption and power management." |
| 3 | HOMEPAGE = "http://01.org/powertop/" |
| 4 | BUGTRACKER = "http://bugzilla.lesswatts.org/" |
| 5 | DEPENDS = "ncurses libnl pciutils" |
| 6 | LICENSE = "GPLv2" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e" |
| 8 | |
| 9 | SRC_URI = "http://01.org/sites/default/files/downloads/powertop/powertop-v${PV}.tar.gz \ |
| 10 | " |
| 11 | |
| 12 | SRC_URI[md5sum] = "583518c5c4434c6e9b9c58c3920950b6" |
| 13 | SRC_URI[sha256sum] = "aa7fb7d8e9a00f05e7d8a7a2866d85929741e0d03a5bf40cab22d2021c959250" |
| 14 | |
| 15 | UPSTREAM_CHECK_URI = "https://01.org/powertop/downloads" |
| 16 | UPSTREAM_CHECK_REGEX = "powertop-[v]?(?P<pver>\d+(\.\d+)+)\.tar" |
| 17 | |
| 18 | inherit autotools gettext pkgconfig |
| 19 | |
| 20 | S = "${WORKDIR}/${BPN}-v${PV}" |
| 21 | |
| 22 | # we do not want libncursesw if we can |
| 23 | do_configure_prepend() { |
| 24 | # configure.ac checks for delwin() in "ncursesw ncurses" so let's drop first one |
| 25 | sed -i -e "s/ncursesw//g" ${S}/configure.ac |
| 26 | mkdir -p ${B}/src/tuning/ |
| 27 | } |
| 28 | |
| 29 | inherit update-alternatives |
| 30 | ALTERNATIVE_${PN} = "powertop" |
| 31 | ALTERNATIVE_TARGET[powertop] = "${sbindir}/powertop" |
| 32 | ALTERNATIVE_LINK_NAME[powertop] = "${sbindir}/powertop" |
| 33 | ALTERNATIVE_PRIORITY = "100" |