Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "High-level GnuPG encryption/signing API" |
| 2 | DESCRIPTION = "GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier for applications. It provides a High-Level Crypto API for encryption, decryption, signing, signature verification and key management" |
| 3 | HOMEPAGE = "http://www.gnupg.org/gpgme.html" |
| 4 | BUGTRACKER = "https://bugs.g10code.com/gnupg/index" |
| 5 | |
| 6 | LICENSE = "GPLv2+ & LGPLv2.1+" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ |
| 8 | file://COPYING.LESSER;md5=bbb461211a33b134d42ed5ee802b37ff \ |
| 9 | file://src/gpgme.h.in;endline=23;md5=2f0bf06d1c7dcb28532a9d0f94a7ca1d \ |
| 10 | file://src/engine.h;endline=22;md5=4b6d8ba313d9b564cc4d4cfb1640af9d" |
| 11 | |
| 12 | UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html" |
| 13 | SRC_URI = "${GNUPG_MIRROR}/gpgme/${BP}.tar.bz2 \ |
| 14 | file://0001-Revert-build-Make-gpgme.m4-use-gpgrt-config-with-.pc.patch \ |
| 15 | file://0001-pkgconfig.patch \ |
| 16 | file://0002-gpgme-lang-python-gpg-error-config-should-not-be-use.patch \ |
| 17 | file://0003-Correctly-install-python-modules.patch \ |
| 18 | file://0004-python-import.patch \ |
| 19 | file://0005-gpgme-config-skip-all-lib-or-usr-lib-directories-in-.patch \ |
| 20 | file://0006-fix-build-path-issue.patch \ |
| 21 | file://0007-python-Add-variables-to-tests.patch \ |
| 22 | file://0008-do-not-auto-check-var-PYTHON.patch \ |
| 23 | " |
| 24 | |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 25 | SRC_URI[sha256sum] = "eebc3c1b27f1c8979896ff361ba9bb4778b508b2496c2fc10e3775a40b1de1ad" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 26 | |
| 27 | DEPENDS = "libgpg-error libassuan" |
| 28 | RDEPENDS_${PN}-cpp += "libstdc++" |
| 29 | |
| 30 | RDEPENDS_python2-gpg += "python-unixadmin" |
| 31 | RDEPENDS_python3-gpg += "python3-unixadmin" |
| 32 | |
| 33 | BINCONFIG = "${bindir}/gpgme-config" |
| 34 | |
| 35 | # Note select python2 or python3, but you can't select both at the same time |
| 36 | PACKAGECONFIG ??= "python3" |
| 37 | PACKAGECONFIG[python2] = ",,python swig-native," |
| 38 | PACKAGECONFIG[python3] = ",,python3 swig-native," |
| 39 | |
| 40 | # Default in configure.ac: "cl cpp python qt" |
| 41 | # Supported: "cl cpp python python2 python3 qt" |
| 42 | # python says 'search and find python2 or python3' |
| 43 | |
| 44 | # Building the C++ bindings for native requires a C++ compiler with C++11 |
| 45 | # support. Since these bindings are currently not needed, we can disable them. |
| 46 | DEFAULT_LANGUAGES = "" |
| 47 | DEFAULT_LANGUAGES_class-target = "cpp" |
| 48 | LANGUAGES ?= "${DEFAULT_LANGUAGES} python" |
| 49 | |
| 50 | PYTHON_INHERIT = "${@bb.utils.contains('PACKAGECONFIG', 'python2', 'pythonnative', '', d)}" |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 51 | PYTHON_INHERIT .= "${@bb.utils.contains('PACKAGECONFIG', 'python3', 'python3native python3targetconfig', '', d)}" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 52 | |
| 53 | EXTRA_OECONF += '--enable-languages="${LANGUAGES}" \ |
| 54 | --disable-gpgconf-test \ |
| 55 | --disable-gpg-test \ |
| 56 | --disable-gpgsm-test \ |
| 57 | --disable-g13-test \ |
| 58 | --disable-lang-python-test \ |
| 59 | ' |
| 60 | |
Andrew Geissler | 635e0e4 | 2020-08-21 15:58:33 -0500 | [diff] [blame] | 61 | inherit autotools texinfo binconfig-disabled pkgconfig distutils-common-base ${PYTHON_INHERIT} multilib_header |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 62 | |
| 63 | export PKG_CONFIG='pkg-config' |
| 64 | |
| 65 | BBCLASSEXTEND = "native nativesdk" |
| 66 | |
| 67 | PACKAGES =+ "${PN}-cpp" |
| 68 | PACKAGES =. "${@bb.utils.contains('PACKAGECONFIG', 'python2', 'python2-gpg ', '', d)}" |
| 69 | PACKAGES =. "${@bb.utils.contains('PACKAGECONFIG', 'python3', 'python3-gpg ', '', d)}" |
| 70 | |
| 71 | FILES_${PN}-cpp = "${libdir}/libgpgmepp.so.*" |
| 72 | FILES_python2-gpg = "${PYTHON_SITEPACKAGES_DIR}/*" |
| 73 | FILES_python3-gpg = "${PYTHON_SITEPACKAGES_DIR}/*" |
| 74 | FILES_${PN}-dev += "${datadir}/common-lisp/source/gpgme/* \ |
| 75 | ${libdir}/cmake/* \ |
| 76 | " |
| 77 | |
| 78 | CFLAGS_append_libc-musl = " -D__error_t_defined " |
| 79 | do_configure_prepend () { |
| 80 | # Else these could be used in preference to those in aclocal-copy |
| 81 | rm -f ${S}/m4/gpg-error.m4 |
| 82 | rm -f ${S}/m4/libassuan.m4 |
| 83 | rm -f ${S}/m4/python.m4 |
| 84 | } |
Andrew Geissler | 635e0e4 | 2020-08-21 15:58:33 -0500 | [diff] [blame] | 85 | |
| 86 | do_install_append() { |
| 87 | oe_multilib_header gpgme.h |
| 88 | } |