Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "Collection of simple PIN or passphrase entry dialogs" |
| 2 | DESCRIPTION = "\ |
| 3 | Pinentry is a collection of simple PIN or passphrase entry dialogs which \ |
| 4 | utilize the Assuan protocol as described by the aegypten project; see \ |
| 5 | http://www.gnupg.org/aegypten/ for details." |
| 6 | |
| 7 | HOMEPAGE = "http://www.gnupg.org/related_software/pinentry/index.en.html" |
| 8 | LICENSE = "GPLv2" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=cbbd794e2a0a289b9dfcc9f513d1996e" |
| 10 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 11 | DEPENDS = "gettext-native libassuan libgpg-error" |
| 12 | |
| 13 | UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html" |
| 14 | SRC_URI = "${GNUPG_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \ |
| 15 | file://libassuan_pkgconf.patch \ |
| 16 | file://gpg-error_pkconf.patch \ |
| 17 | " |
| 18 | |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 19 | SRC_URI[sha256sum] = "cd12a064013ed18e2ee8475e669b9f58db1b225a0144debdb85a68cecddba57f" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 20 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 21 | inherit autotools pkgconfig |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 22 | |
| 23 | PACKAGECONFIG ??= "ncurses libcap" |
| 24 | |
| 25 | PACKAGECONFIG[ncurses] = "--enable-ncurses --with-ncurses-include-dir=${STAGING_INCDIR}, --disable-ncurses, ncurses" |
| 26 | PACKAGECONFIG[libcap] = "--with-libcap, --without-libcap, libcap" |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 27 | PACKAGECONFIG[qt] = "--enable-pinentry-qt, --disable-pinentry-qt, qtbase-native qtbase" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 28 | PACKAGECONFIG[gtk2] = "--enable-pinentry-gtk2, --disable-pinentry-gtk2, gtk+ glib-2.0" |
| 29 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 30 | PACKAGECONFIG[secret] = "--enable-libsecret, --disable-libsecret, libsecret" |
| 31 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 32 | EXTRA_OECONF = " \ |
| 33 | --disable-rpath \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 34 | " |
| 35 | |
Brad Bishop | 1d80a2e | 2019-11-15 16:35:03 -0500 | [diff] [blame] | 36 | BBCLASSEXTEND = "native nativesdk" |