William A. Kennington III | b2c5306 | 2021-02-09 17:48:19 -0800 | [diff] [blame] | 1 | LICENSE = "BSD" |
| 2 | LIC_FILES_CHKSUM = "file://COPYING;md5=1b886630cdc9a17c26250934beda407d" |
| 3 | |
| 4 | PV = "0.1+git${SRCPV}" |
| 5 | SRC_URI = "git://github.com/yrutschle/conf2struct" |
| 6 | SRCREV = "e8468017b27211b1c452f8df0afe6f19e97035a4" |
| 7 | S = "${WORKDIR}/git" |
| 8 | |
| 9 | SRC_URI += " \ |
| 10 | file://0001-makefile-Add-missing-LDFLAGS.patch \ |
| 11 | file://0001-conf2struct-Use-the-right-perl.patch \ |
| 12 | " |
| 13 | |
| 14 | inherit native |
| 15 | |
| 16 | DEPENDS += " \ |
| 17 | libconfig-native \ |
| 18 | libconfig-perl-native \ |
| 19 | " |
| 20 | |
| 21 | EXTRA_OEMAKE += " \ |
| 22 | DESTDIR=${D} \ |
| 23 | prefix=${prefix} \ |
| 24 | " |
| 25 | |
| 26 | do_compile() { |
| 27 | oe_runmake checker |
| 28 | } |
| 29 | |
| 30 | do_install() { |
| 31 | oe_runmake install |
| 32 | } |