Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 1 | SUMMARY = "libva-utils is a collection of utilities from libva project" |
| 2 | |
| 3 | DESCRIPTION = "libva-utils is a collection of utilities \ |
| 4 | and examples to exercise VA-API in accordance with the libva \ |
| 5 | project.VA-API is an open-source library and API specification, \ |
| 6 | which provides access to graphics hardware acceleration capabilities \ |
| 7 | for video processing. It consists of a main library and driver-specific \ |
| 8 | acceleration backends for each supported hardware vendor" |
| 9 | |
| 10 | HOMEPAGE = "https://01.org/linuxmedia/vaapi" |
| 11 | BUGTRACKER = "https://github.com/intel/libva-utils/issues" |
| 12 | |
| 13 | SECTION = "x11" |
| 14 | LICENSE = "MIT" |
| 15 | LIC_FILES_CHKSUM = "file://COPYING;md5=b148fc8adf19dc9aec17cf9cd29a9a5e" |
| 16 | |
| 17 | SRC_URI = "git://github.com/intel/libva-utils.git;branch=v2.14-branch;protocol=https" |
| 18 | SRCREV = "9cf21686ad9cacef53ee6b3f13c02b830cf0c7a3" |
| 19 | S = "${WORKDIR}/git" |
| 20 | |
| 21 | UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+)+))$" |
| 22 | |
| 23 | DEPENDS = "libva" |
| 24 | |
| 25 | inherit meson pkgconfig features_check |
| 26 | |
| 27 | # depends on libva which requires opengl |
| 28 | REQUIRED_DISTRO_FEATURES = "opengl" |
| 29 | |
| 30 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}" |
| 31 | PACKAGECONFIG[x11] = "-Dx11=true, -Dx11=false,virtual/libx11 libxext libxfixes" |
| 32 | PACKAGECONFIG[wayland] = "-Dwayland=true, -Dwayland=false,wayland-native wayland" |